Bug 25399 - Memory leak in /usr/sbin/snmpd
Memory leak in /usr/sbin/snmpd
Status: CLOSED DUPLICATE of bug 30957
Product: Red Hat Linux
Classification: Retired
Component: ucd-snmp (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-31 15:52 EST by Andrei Ivanov
Modified: 2015-03-04 20:08 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-07 14:32:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrei Ivanov 2001-01-31 15:52:58 EST
Due to memory leak in /usr/sbin/snmpd computer may exhaust memory and
swap space available, and then "freeze".

One of my servers is polled (by MRTG) every five minutes. But now I found
that the computer, running MRTG, is not the only one who sends SNMP
requests (this particular server in question is located not on my own
network). Once every six seconds one of remote servers sends SNMP requests
to broadcast address:

    13:07:27.520614 eth0 B 10.40.1.42.4881 > 255.255.255.255.snmp:
                  GetRequest(41) .1.3.6.1.2.1.1.2.0 .1.3.6.1.2.1.2.2.1.6.1
    13:07:33.830208 eth0 B 10.40.1.42.4947 > 255.255.255.255.snmp:
                  GetRequest(41) .1.3.6.1.2.1.1.2.0 .1.3.6.1.2.1.2.2.1.6.1
    13:07:39.798000 eth0 B 10.40.1.42.4987 > 255.255.255.255.snmp:
                  GetRequest(41) .1.3.6.1.2.1.1.2.0 .1.3.6.1.2.1.2.2.1.6.1
    13:07:45.737278 eth0 B 10.40.1.42.1048 > 255.255.255.255.snmp:
                  GetRequest(41) .1.3.6.1.2.1.1.2.0 .1.3.6.1.2.1.2.2.1.6.1
    13:07:52.036401 eth0 B 10.40.1.42.1114 > 255.255.255.255.snmp:
                  GetRequest(41) .1.3.6.1.2.1.1.2.0 .1.3.6.1.2.1.2.2.1.6.1

Look at the ps output (VSZ/RSS):

  # date ; ps -aux | egrep 'RSS|snmpd'
  Sat Jan 27 19:04:30 PST 2001
  USER PID %CPU %MEM VSZ RSS TTY STAT START TIME COMMAND
  root 1105 0.1 3.3 3232 2096 pts/0 S 18:47 0:01 /usr/sbin/snmpd
  # date ; ps -aux | egrep 'RSS|snmpd' 
  Mon Jan 29 12:56:53 PST 2001
  USER PID %CPU %MEM VSZ RSS TTY STAT START TIME COMMAND
  root 1105 0.0 50.0 47860 31560 ? S Jan27 1:13 /usr/sbin/snmpd

This picture was observed with ucd-snmp-4.1.1-2 package, as shipped with
RedHat 6.2. Later I've upgraded to ucd-snmp-4.1.2-8 (took .src.rpm from
RedHat 7.0 distro and compiled it under RedHat 6.2 (standard kernel
2.2.14-5.0). The problem still persists:

  # date ; ps -aux | egrep 'RSS|snmpd' 
  Mon Jan 29 12:59:16 PST 2001
  USER PID %CPU %MEM VSZ RSS TTY STAT START TIME COMMAND
  root 6537 9.2 2.7 3176 1732 pts/3 S 12:59 0:00 /usr/sbin/snmpd
  # date ; ps -aux | egrep 'RSS|snmpd'                     
  Wed Jan 31 12:02:52 PST 2001
  USER PID %CPU %MEM VSZ RSS TTY STAT START TIME COMMAND
  root 6537 0.0 68.9 54144 43492 ? S Jan29 0:59 /usr/sbin/snmpd
Comment 1 Phil Knirsch 2001-06-26 10:15:50 EDT
Fixed in rawhide due to update to 4.2.1.

Read ya, Phil

*** This bug has been marked as a duplicate of 30957 ***

Note You need to log in before you can comment on or make changes to this bug.