Bug 253996 - Sabayon ignores mandatory attribute for files
Sabayon ignores mandatory attribute for files
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: sabayon (Show other bugs)
5.0
All Linux
low Severity low
: ---
: ---
Assigned To: Tomáš Bžatek
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-23 10:56 EDT by Josko Plazonic
Modified: 2015-07-13 15:33 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 09:21:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
plazonic: needinfo-


Attachments (Terms of Use)
Patch fixing bad conversion of string into boolean. (640 bytes, patch)
2007-08-23 10:56 EDT, Josko Plazonic
no flags Details | Diff

  None (edit)
Description Josko Plazonic 2007-08-23 10:56:36 EDT
Description of problem:
Due to a bug in handling booleans sabayon ignores mandatory flag when applying
profiles.  All files are treated as mandatory and they overwrite already present
files.

Version-Release number of selected component (if applicable):
sabayon-2.12.4-3.el5

How reproducible:
Every time.

Steps to Reproduce:
1. Have a sabayon profile with a file, say (excerpt from metadata):
    <file path=".gnome2/mail-notification/mailboxes.xml" timestamp="1186147559"
user="sabayon" host="testhost">
      <source>Files</source>
      <attributes>
        <attribute name="mandatory" value="False"/>
      </attributes>
    </file>
2. Apply profile
3. Change above file
4. Apply profile again
5. Notice that the file got reset
 
Actual results:
Profile overwrites already present file every time.

Expected results:
Should not overwrite files when they are not marked as mandatory=True

Additional info:
Bug in handling bool(string).  Patch attached and pretty self explanatory.
Comment 1 Josko Plazonic 2007-08-23 10:56:36 EDT
Created attachment 168899 [details]
Patch fixing bad conversion of string into boolean.
Comment 2 Heath Petty 2008-01-17 15:22:03 EST
This patch has been applied upstream in revision 911 as reported by a community
member. 
Comment 3 Josko Plazonic 2008-01-17 15:40:58 EST
Not sure which revision you are referring to but couldn't find any fixes on
cvs.gnome.org/viewcvs/sabayon though maybe it was fixed in a different fashion.

Also the fix is not in RHEL 5.1 - had to add the above patch to prevent user
config files from being overwritten.
Comment 4 Josko Plazonic 2008-01-17 15:44:22 EST
Doah - please ignore the last comment - didn't notice they switched to
subversion and was looking at CVS :(... Sorry about that - Heath is absolutely
correct - the fix is indeed in the sabayon subversion repo.
Comment 5 Tomáš Bžatek 2008-09-11 12:03:35 EDT
I believe this will be fixed in sabayon-2.12.4-6.el5 since we basically did rebase sabayon in order to fix bug 442132 which also includes the fix reported in comment #1.

Once the update will be published, I will provide more information.
Comment 6 RHEL Product and Program Management 2014-03-07 07:51:56 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 7 RHEL Product and Program Management 2014-06-02 09:21:22 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.