Bug 442132 - Sabayon errors when saving profiles
Sabayon errors when saving profiles
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: sabayon (Show other bugs)
5.1
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Tomáš Bžatek
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-11 18:34 EDT by Charlie Wyse
Modified: 2015-03-03 17:32 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-15 11:08:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch based on upstream code (4.48 KB, patch)
2008-07-03 14:35 EDT, ritz
no flags Details | Diff

  None (edit)
Description Charlie Wyse 2008-04-11 18:34:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9b5pre) Gecko/2008030509 Red Hat/3.0b5pre-0.beta4.1.el5 Minefield/3.0b5pre

Description of problem:
When trying to save a profile sabayon spits out a lot of errors.  It seems to save the profile, however I can not set that profile to any users.

Version-Release number of selected component (if applicable):
sabayon-2.12.4-5.el5

How reproducible:
Always


Steps to Reproduce:
1. Start Sabayon.
2. Create a profile.
3. Modify the profile in any way.
4. Save the profile.

Actual Results:
root@magic [:~] %sabayon                                                                                                                        [15:18:57]
Traceback (most recent call last):
  File "/usr/lib64/python2.4/site-packages/sabayon/sessionwindow.py", line 233, in __do_save
    change.get_source ().commit_change (change, mandatory)
  File "/usr/lib64/python2.4/site-packages/sabayon/sources/filessource.py", line 117, in commit_change
    { "mandatory" : mandatory })
  File "/usr/lib64/python2.4/site-packages/sabayon/storage.py", line 372, in add
    copy_tree (self.temp_path, src_dir, path)
  File "/usr/lib64/python2.4/site-packages/sabayon/storage.py", line 57, in copy_tree
    raise err
OSError: [Errno 2] No such file or directory: '/tmp/sabayon-profile-storage-tGsMZV/.gnome2/accels'
Traceback (most recent call last):
  File "/usr/lib64/python2.4/site-packages/sabayon/sessionwindow.py", line 233, in __do_save
    change.get_source ().commit_change (change, mandatory)
  File "/usr/lib64/python2.4/site-packages/sabayon/sources/filessource.py", line 117, in commit_change
    { "mandatory" : mandatory })
  File "/usr/lib64/python2.4/site-packages/sabayon/storage.py", line 372, in add
    copy_tree (self.temp_path, src_dir, path)
  File "/usr/lib64/python2.4/site-packages/sabayon/storage.py", line 57, in copy_tree
    raise err
OSError: [Errno 2] No such file or directory: '/tmp/sabayon-profile-storage-tGsMZV/.gnome2/nautilus-scripts'
Traceback (most recent call last):
  File "/usr/lib64/python2.4/site-packages/sabayon/sessionwindow.py", line 233, in __do_save
    change.get_source ().commit_change (change, mandatory)
  File "/usr/lib64/python2.4/site-packages/sabayon/sources/filessource.py", line 117, in commit_change
    { "mandatory" : mandatory })
  File "/usr/lib64/python2.4/site-packages/sabayon/storage.py", line 372, in add
    copy_tree (self.temp_path, src_dir, path)
  File "/usr/lib64/python2.4/site-packages/sabayon/storage.py", line 57, in copy_tree
    raise err
OSError: [Errno 2] No such file or directory: '/tmp/sabayon-profile-storage-tGsMZV/.gnome2/keyrings'
Traceback (most recent call last):
  File "/usr/lib64/python2.4/site-packages/sabayon/sessionwindow.py", line 233, in __do_save
    change.get_source ().commit_change (change, mandatory)
  File "/usr/lib64/python2.4/site-packages/sabayon/sources/filessource.py", line 117, in commit_change
    { "mandatory" : mandatory })
  File "/usr/lib64/python2.4/site-packages/sabayon/storage.py", line 372, in add
    copy_tree (self.temp_path, src_dir, path)
  File "/usr/lib64/python2.4/site-packages/sabayon/storage.py", line 57, in copy_tree
    raise err
OSError: [Errno 2] No such file or directory: '/tmp/sabayon-profile-storage-tGsMZV/.gnome2/share'
Traceback (most recent call last):
  File "/usr/lib64/python2.4/site-packages/sabayon/sessionwindow.py", line 233, in __do_save
    change.get_source ().commit_change (change, mandatory)
  File "/usr/lib64/python2.4/site-packages/sabayon/sources/filessource.py", line 117, in commit_change
    { "mandatory" : mandatory })
  File "/usr/lib64/python2.4/site-packages/sabayon/storage.py", line 372, in add
    copy_tree (self.temp_path, src_dir, path)
  File "/usr/lib64/python2.4/site-packages/sabayon/storage.py", line 57, in copy_tree
    raise err
OSError: [Errno 2] No such file or directory: '/tmp/sabayon-profile-storage-tGsMZV/.gnome2/share/cursor-fonts'
Traceback (most recent call last):
  File "/usr/lib64/python2.4/site-packages/sabayon/sessionwindow.py", line 233, in __do_save
    change.get_source ().commit_change (change, mandatory)
  File "/usr/lib64/python2.4/site-packages/sabayon/sources/filessource.py", line 117, in commit_change
    { "mandatory" : mandatory })
  File "/usr/lib64/python2.4/site-packages/sabayon/storage.py", line 372, in add
    copy_tree (self.temp_path, src_dir, path)
  File "/usr/lib64/python2.4/site-packages/sabayon/storage.py", line 57, in copy_tree
    raise err
OSError: [Errno 2] No such file or directory: '/tmp/sabayon-profile-storage-tGsMZV/.gnome2/share/fonts'
Traceback (most recent call last):
  File "/usr/lib64/python2.4/site-packages/sabayon/sessionwindow.py", line 233, in __do_save
    change.get_source ().commit_change (change, mandatory)
  File "/usr/lib64/python2.4/site-packages/sabayon/sources/filessource.py", line 117, in commit_change
    { "mandatory" : mandatory })
  File "/usr/lib64/python2.4/site-packages/sabayon/storage.py", line 372, in add
    copy_tree (self.temp_path, src_dir, path)
  File "/usr/lib64/python2.4/site-packages/sabayon/storage.py", line 57, in copy_tree
    raise err
OSError: [Errno 2] No such file or directory: '/tmp/sabayon-profile-storage-tGsMZV/.redhat/esc'
Traceback (most recent call last):
  File "/usr/lib64/python2.4/site-packages/sabayon/sessionwindow.py", line 233, in __do_save
    change.get_source ().commit_change (change, mandatory)
  File "/usr/lib64/python2.4/site-packages/sabayon/sources/filessource.py", line 117, in commit_change
    { "mandatory" : mandatory })
  File "/usr/lib64/python2.4/site-packages/sabayon/storage.py", line 372, in add
    copy_tree (self.temp_path, src_dir, path)
  File "/usr/lib64/python2.4/site-packages/sabayon/storage.py", line 57, in copy_tree
    raise err
OSError: [Errno 2] No such file or directory: '/tmp/sabayon-profile-storage-tGsMZV/.gnome/gnome-vfs'
Traceback (most recent call last):
  File "/usr/lib64/python2.4/site-packages/sabayon/sessionwindow.py", line 233, in __do_save
    change.get_source ().commit_change (change, mandatory)
  File "/usr/lib64/python2.4/site-packages/sabayon/sources/filessource.py", line 117, in commit_change
    { "mandatory" : mandatory })
  File "/usr/lib64/python2.4/site-packages/sabayon/storage.py", line 372, in add
    copy_tree (self.temp_path, src_dir, path)
  File "/usr/lib64/python2.4/site-packages/sabayon/storage.py", line 57, in copy_tree
    raise err
OSError: [Errno 2] No such file or directory: '/tmp/sabayon-profile-storage-tGsMZV/.dbus/session-bus'
The application '-c' lost its connection to the display :1.0;
most likely the X server was shut down or you killed/destroyed
the application.
Traceback (most recent call last):
  File "/usr/lib64/python2.4/site-packages/sabayon/profilesdialog.py", line 395, in __remove_button_clicked
    self.__delete_currently_selected ()
  File "/usr/lib64/python2.4/site-packages/sabayon/profilesdialog.py", line 371, in __delete_currently_selected
    os.remove (_get_profile_path_for_name (profile_name))
OSError: [Errno 2] No such file or directory: '/etc/desktop-profiles/another.zip'


Expected Results:
It should save the profile with no error.  Then when I select a user that user should be able to boot up with said profile.

Additional info:
We receive our user list through ldap.  Each users home directory has root_squash and is mounted via autofs from a netapp filer.
Comment 1 Charlie Wyse 2008-04-11 18:35:30 EDT
If I go back into sabayon and view the profile I get the following error:

Traceback (most recent call last):
  File "/usr/sbin/sabayon-apply", line 56, in ?
    profile.apply (is_sabayon_session)
  File "/usr/lib64/python2.4/site-packages/sabayon/userprofile.py", line 389, in
apply
    s.apply (is_sabayon_session)
  File "/usr/lib64/python2.4/site-packages/sabayon/sources/filessource.py", line
148, in apply
    self.storage.foreach (self.__apply_foreach, source = self.name)
  File "/usr/lib64/python2.4/site-packages/sabayon/storage.py", line 560, in foreach
    self.__foreach_node (node, callback, user_data, source)
  File "/usr/lib64/python2.4/site-packages/sabayon/storage.py", line 540, in
__foreach_node
    callback (item_source, item_path)
  File "/usr/lib64/python2.4/site-packages/sabayon/sources/filessource.py", line
145, in __apply_foreach
    self.storage.extract (path, self.home_dir, mandatory)
  File "/usr/lib64/python2.4/site-packages/sabayon/storage.py", line 499, in extract
    copy_tree (dst_dir, self.temp_path, path, None, overwrite)
  File "/usr/lib64/python2.4/site-packages/sabayon/storage.py", line 57, in
copy_tree
    raise err
OSError: [Errno 2] No such file or directory:
'/tmp/sabayon-temp-home-BUKyZG/.gnome2/accels'
The application '-c' lost its connection to the display :1.0;
most likely the X server was shut down or you killed/destroyed
the application.
Comment 3 ritz 2008-07-03 14:35:38 EDT
Created attachment 310947 [details]
patch based on upstream code

http://bugzilla.gnome.org/show_bug.cgi?id=476761
Bug 476761 – Profile zipfiles have duplicated files

------------------------------

I threw this in for _extra_ . This is not the bug in question.

https://bugzilla.redhat.com/show_bug.cgi?id=253996
Bugzilla Bug 253996: Sabayon ignores mandatory attribute for files
Comment 4 Matthias Clasen 2008-07-07 12:44:48 EDT
Patch available, dev ack +
Comment 6 Charlie Wyse 2008-07-07 18:11:41 EDT
Resolving this ticket as well as IT174444, everything looks to be working now. 
The messages are a bit to verbose and should be cleaned up, but that's a
separate issue.
Comment 8 Bryan Mason 2008-07-08 12:32:56 EDT
The VERIFIED status should only be used once this Bug has been tested by QE, and
 has passed the testing.  See
https://bugzilla.redhat.com/page.cgi?id=fields.html#bug_status for more
information on the lifecycle of a Bug.

Changing status to ASSIGNED...
Comment 9 RHEL Product and Program Management 2008-07-21 19:03:36 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 18 errata-xmlrpc 2008-10-15 11:08:10 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0900.html
Comment 21 Tomáš Bžatek 2011-10-04 10:48:34 EDT
*** Bug 505402 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.