Bug 254005 - Unhandled Exception when using Software Updater in GNOME
Unhandled Exception when using Software Updater in GNOME
Status: CLOSED DUPLICATE of bug 251836
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
7
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-23 11:57 EDT by Scott Hair
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-23 12:49:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
pirut Dump File (17.25 KB, application/octet-stream)
2007-08-23 12:01 EDT, Scott Hair
no flags Details

  None (edit)
Description Scott Hair 2007-08-23 11:57:54 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.5) Gecko/20070718 Fedora/2.0.0.5-1.fc7 Firefox/2.0.0.5

Description of problem:
When I went to update programs using the software updater, I clicked on the Applications -> System Tools -> Software Updater, nothing happened. Iam using the GNOME desktop. After about 30-60 seconds, the Unhandled Exception occured with the following traceback file. (See attached.)

Component: pirut
Summary: TB9536d0ca <string>:64:__iter__:SyntaxError: not well-formed (invalid token): line 13017, column 10

Traceback (most recent call last):
  File "/usr/sbin/pirut", line 441, in <module>
    main()
  File "/usr/sbin/pirut", line 434, in main
    pm = PackageManager(options.config, options.onlyrepo)
  File "/usr/sbin/pirut", line 61, in __init__
    GraphicalYumBase.__init__(self, False, config)
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 124, in __init__
    self.reset()
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 226, in reset
    self.doGroupSetup()
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 426, in doGroupSetup
    return self._getGroups()
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 474, in _getGroups
    self._comps.add(groupfile)
  File "/usr/lib/python2.5/site-packages/yum/comps.py", line 349, in add
    for event, elem in parser:
  File "<string>", line 64, in __iter__
SyntaxError: not well-formed (invalid token): line 13017, column 10

Local variables in innermost frame:
b: <TreeBuilder object at 0x9d5e1a8>
self: <iterparse object at 0x9db0a4c>
events: []
p: <XMLParser object at 0x9d5cce0>
data: ">ভাষা</name>
    <name xml:lang="bn_IN">ভাষা</name>
    <name xml:lang="bs">Jezici</name>
    <name xml:lang="ca">Llengües</name>
    <name xml:lang="cs">Jazyky</name>
    <name xml:lang="cy">Ieithoedd</name>
    <name xml:lang="da">Sprogunderstøttelse</name>
    <name xml:lang="de">Sprachen</name>
    <name xml:lang="el">Γλώσσες</name>
    <name xml:lang="es">Idiomas</name>
    <name xml:lang="fi">Kielet</name>
    <name xml:lang="fr">Langues</name>
    <name xml:lang="gu">ભાષાઓ</name>
    <name xml:lang="hi">भाषायें</name>
    <name xml:lang="hr">Jezici</name>
    <name xml:lang="hu">Nyelvi támogatások</name>
    <name xml:lang="hy">Լեզուներ</name>
    <name xml:lang="id">Bahasa</name>
    <name xml:lang="ilo">Pagsasao</name>
    <name xml:lang="is">Tungumál</name>
    <name xml:lang="it">Linguaggi</name>
    <name xml:lang="ja">言語</name>
    <name xml:lang="ka">ენები</name>
    <name xml:lang="kn">ಭಾಷೆಗಳು</name>
    <name xml:lang="ko">언어 지원</name>
    <name xml:lang="lv">Valodas</name>
    <name xml:lang="ml">ഭാഷകള്‍</name>
    <name xml:lang="mr">भाषा</name>
    <name xml:lang="ms">Bahasa</name>
    <name xml:lang="nb">Språk</name>
    <name xml:lang="nl">Talen</name>
    <name xml:lang="or">ଭାଷା</name>
    <name xml:lang="pa">ਭਾਸ਼ਾਵਾਂ</name>
    <name xml:lang="pl">Języki</name>
    <name xml:lang="pt">Línguas</name>
    <name xml:lang="pt_BR">Idiomas</name>
    <name xml:lang="ro">Limbi</name>
    <name xml:lang="ru">Языки</name>
    <name xml:lang="si">භාශාවන්</name>
    <name xml:lang="sk">Jazyky</name>
    <name xml:lang="sl">Jeziki</name>
    <name xml:lang="sr">Језици</name>
    <name xml:lang="sr@Latn">Jezici</name>
    <name xml:lang="sv">Språkstöd</name>
    <name xml:lang="ta">மொழிகள்</name>
    <name xml:lang="te">భాషలు</name>
    <name xml:lang="th">ภาษา</name>
    <name xml:lang="tr">Diller</name>
    <name xml:lang="uk">Мови</name>
    <name xml:lang="zh_CN">语言支持</name>
    <name xml:lang="zh_TW">語言</name>
    <description>These packages provide support for various locales including fonts and input methods.</description>
    <description xml:lang="am">እነዚህ ጥቅሎች ለተለያዩ ውስጣዊዎች የጽሑፍ ዓይነቶች እና የማስገቢያ ዘዴዎች ተስማሚ የሆነ ድጋፍ ያቀርባሉ።</description>
    <description xml:lang="as">এই সৰঞ্জাম সমূহে বিভিন্ন অৱস্থানৰ লগত আখৰ আৰু নিবেশ পদ্ধতিৰ সমৰ্থনৰ যোগান ধৰে ।</description>
    <description xml:lang="bg">Пакетите осигуряват поддръжката за различни региони - включително фонтове и методи за въвеждане.</description>
    <description xml:lang="bn">এই প্যাকেজগুলোতে বিভিন্ন লোকাল-এর (Locale) সমর্থন রয়েছে; এর অংশ হল ফন্ট ও ইনপুট পদ্ধতি (মেথড) ।</description>
    <description xml:lang="bn_IN">এই প্যাকেজ সংকলনগুলি, ফন্ট ও ইনপুট পদ্ধতিসহ বিভিন্ন লেকেইল ব্যবহারের জন্য সমর্থন উপলব্ধ করে।</description>
    <description xml:lang="bs">Ovi paketi omogućuju podršku za različite lokalizacije, uključujući i lokalne fontove i tipkovnice</description>

Version-Release number of selected component (if applicable):
pirut-1.3.9-1.fc7

How reproducible:
Didn't try


Steps to Reproduce:
1. Click Applications
2. System Tools
3. Software Updater

Then nothing on the screen....

Actual Results:
No Window popped up like it used to.....then eventually the Unhandled Exception window. Also system is running extremely slow now.

Expected Results:
Software updater window should have been displayed.

Additional info:
Comment 1 Scott Hair 2007-08-23 12:01:07 EDT
Created attachment 169290 [details]
pirut Dump File

This is the actual dump file created when the unhandled exception occurred.
Comment 2 Jeremy Katz 2007-08-23 12:49:00 EDT

*** This bug has been marked as a duplicate of 251836 ***

Note You need to log in before you can comment on or make changes to this bug.