Bug 254010 - Redhat bugzilla takes too long to load
Redhat bugzilla takes too long to load
Status: CLOSED DUPLICATE of bug 458696
Product: Bugzilla
Classification: Community
Component: User Interface (Show other bugs)
3.2
All All
high Severity high (vote)
: ---
: ---
Assigned To: Web Development
Web Development
: Reopened
Depends On:
Blocks: 474289
  Show dependency treegraph
 
Reported: 2007-08-23 12:45 EDT by Hasan Ceylan
Modified: 2009-01-26 21:57 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-26 21:57:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hasan Ceylan 2007-08-23 12:45:43 EDT
Description of problem:
Fedora bug report page is 800+KB long. It takes hell a lot of time to load the
page. Therefore reporting bugs etc takes a long time for Fedora. I did not check
the other products of redhat bugzilla pages but this might apply to them as well.

Version-Release number of selected component (if applicable):
N/A

How reproducible:
Everytime

Steps to Reproduce:
1.Go to bugzilla.redhat.com
2.Login and try to report a bug for fedora
3.Save the page and look for the size of the page
  
Actual results:
800+ KB

Expected results:
no more then 100K

Additional info:
1) The page can be broken into parts like, externalizing the embedded java
script. Java scripts can still be dynamically generated but can be set as cachable. 
2) Global application can keep date and times for the seldom changing parts and
return not changed HTTP header as long as the cached version is OK
3) Server can be configured to gzip the html content

This might seem to be small issue but since it takes a lot of time to report a
simple problem, it will reduce the number of "misses" as people might avoid
reporting bugs as it is painful.

Regards,
Hasan Ceylan
Comment 1 David Lawrence 2007-09-26 15:40:07 EDT
This should be better now. Please reopen this bug if this is still a problem.
Comment 2 Hasan Ceylan 2007-09-26 16:22:21 EDT
Dear David,

Thank you for taking care of that.

It is better but still I find the size uncomfortable to use.

would it put too much burden on your servers to make is gzip'ed stream? That
would help a lot...

Hasan Ceylan
Comment 3 Steve Siano 2007-11-01 22:44:30 EDT
The current size of 350 kB is still a bit excessive.

Maybe the Products list should have an All value, as do the Versions and
Components lists.  Then, the Versions list should be updated using AJAX once a
Product is chosen, and the Components list should be updated using AJAX once a
Version is chosen.  Thus, the full list of Versions would only be sent if the
user chose All for Products.  And in all other cases, less information would be
sent than currently.
Comment 4 Hasan Ceylan 2007-11-01 23:00:14 EDT
Why not go with the gzipped HTML output from apache?
Would that not be the less painful solution?

Regards,
Hasan Ceylan
Comment 5 Hasan Ceylan 2008-08-21 02:44:42 EDT
I am aware of Redhat's commitment to get Linux / Fedora to everyone including the poor and developing countries.

I am on a much larger broadband connection now and this bug does not affect me much any more.

But for those that are still trying to get their way out with limited connection cannot use Fedora Bugzilla.

A simple gzip addition to the apache that serves redhat bugzilla would do. 

When there is such a small solution, I do not think this bug has the attention it deserves...

Ceylan
Comment 6 David Lawrence 2008-09-16 12:55:25 EDT
Red Hat Bugzilla is now using version 3.2 of the Bugzilla codebase and therefore this bug will need to be re-verified against the new release. With the updated code this bug may no longer be relevant or may have been fixed in the new code.
Updating bug version to 3.2.
Comment 7 Hasan Ceylan 2008-09-17 07:28:00 EDT
Nope,

it is the size of the data, and I think it has nothing to do with the code.

Why not comment on gzipped stream alternative?

Ceylan
Comment 8 Noura El hawary 2009-01-26 21:57:17 EST

*** This bug has been marked as a duplicate of bug 458696 ***

Note You need to log in before you can comment on or make changes to this bug.