This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 254238 - bind-9.4.2-0.1.b1.fc7 causes twinkle to consume all memory
bind-9.4.2-0.1.b1.fc7 causes twinkle to consume all memory
Status: CLOSED DUPLICATE of bug 254501
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-24 17:52 EDT by Kevin Fenzi
Modified: 2013-04-30 19:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-29 02:26:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Kevin Fenzi 2007-08-24 17:52:48 EDT
Description of problem:

Upgrading to the bind-9.4.2-0.1.b1.fc7 packages in fedora 7 updates-testing
causes the twinkle application (which is linked to libbind) to go into a loop,
consume all memory and eventually crash the machine. ;( 

Moving back to the previous bind version makes it work again just fine. 

Doing an strace on twinkle when it's freaking out shows its looping in this: 

3138  brk(0x8e83d000)                   = 0x8e83d000
3138  open("/etc/irs.conf", O_RDONLY)   = -1 ENOENT (No such file or directory)
3138  open("/etc/hesiod.conf", O_RDONLY) = -1 ENOENT (No such file or directory)
3138  open("/etc/irs.conf", O_RDONLY)   = -1 ENOENT (No such file or directory)
3138  open("/etc/hesiod.conf", O_RDONLY) = -1 ENOENT (No such file or directory)
3138  open("/etc/irs.conf", O_RDONLY)   = -1 ENOENT (No such file or directory)
3138  brk(0x8e85f000)                   = 0x8e85f000
3138  open("/etc/hesiod.conf", O_RDONLY) = -1 ENOENT (No such file or directory)
3138  open("/etc/irs.conf", O_RDONLY)   = -1 ENOENT (No such file or directory)
3138  open("/etc/hesiod.conf", O_RDONLY) = -1 ENOENT (No such file or directory)
3138  open("/etc/irs.conf", O_RDONLY)   = -1 ENOENT (No such file or directory)
3138  open("/etc/hesiod.conf", O_RDONLY) = -1 ENOENT (No such file or directory)
3138  brk(0x8e880000) 

This could of course be a twinkle bug. I will try rebuilding against the current
bind. However, if this update breaks existing apps, it sounds like it might be
an issue in bind. 

Happy to test or provide more info.
Comment 1 Adam Tkac 2007-08-29 02:26:39 EDT

*** This bug has been marked as a duplicate of 254501 ***

Note You need to log in before you can comment on or make changes to this bug.