Bug 254501 - Freeciv server segfaults when client connect with new bind-libs
Summary: Freeciv server segfaults when client connect with new bind-libs
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: bind
Version: 7
Hardware: All
OS: All
medium
low
Target Milestone: ---
Assignee: Adam Tkac
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 150288 254221 254238 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-08-25 22:23 UTC by Henning Norén
Modified: 2013-04-30 23:37 UTC (History)
5 users (show)

Fixed In Version: 9.4.2-0.3.b1.fc7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-09-07 17:20:43 UTC
Type: ---


Attachments (Terms of Use)
gdb stack trace (57.46 KB, application/x-gzip)
2007-08-25 22:23 UTC, Henning Norén
no flags Details
complete strace output of the crash (8.17 KB, application/x-gzip)
2007-08-25 22:25 UTC, Henning Norén
no flags Details

Description Henning Norén 2007-08-25 22:23:45 UTC
Description of problem:
Starting with the latest bind-libs, civserver always crashes when a client
connects. 
Civserver works just fine when reverting back to the last release of bind-libs
and bind-utils (9.4.1-9.P1.fc7)

Version-Release number of selected component (if applicable):
bind-libs-9.4.2-0.1.b1.fc7
bind-utils-9.4.2-0.1.b1.fc7
bind-debuginfo-9.4.2-0.1.b1.fc7
freeciv-2.0.9-1.fc7
freeciv-debuginfo-2.0.9-1.fc7

How reproducible:
Always

Steps to Reproduce:
1. run civclient and try to start a new game
or, for easier debugging:
1. run civserver
2. run civclient -a -s localhost -p 5555
  
Actual results:
civserver segfaults

Comment 1 Henning Norén 2007-08-25 22:23:45 UTC
Created attachment 172661 [details]
gdb stack trace

Comment 2 Henning Norén 2007-08-25 22:25:43 UTC
Created attachment 172681 [details]
complete strace output of the crash

Comment 3 Adam Tkac 2007-08-29 06:26:49 UTC
*** Bug 254238 has been marked as a duplicate of this bug. ***

Comment 4 Adam Tkac 2007-08-29 06:27:04 UTC
*** Bug 254221 has been marked as a duplicate of this bug. ***

Comment 5 Adam Tkac 2007-08-29 06:38:28 UTC
could anyone test
http://people.redhat.com/atkac/bind/bind-9.4.2-0.1.1.b1.fc7.src.rpm and tell me
if problem still exists, please?

Adam

Comment 6 Henning Norén 2007-08-29 16:25:34 UTC
Hi Adam,

I just tried reproducing with the rpms built from the srpm above and it seems
like it is fixed.

Sincerely,
Henning

Comment 7 Kevin Fenzi 2007-08-29 17:55:45 UTC
This version also solves the problem twinkle was having. 


Comment 8 Adam Tkac 2007-08-30 14:48:24 UTC
*** Bug 150288 has been marked as a duplicate of this bug. ***

Comment 9 Fedora Update System 2007-09-04 22:06:14 UTC
bind-9.4.2-0.2.b1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2007-09-07 17:20:42 UTC
bind-9.4.2-0.3.b1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2007-10-24 07:02:03 UTC
bind-9.4.2-0.2.b1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.