Bug 254501 - Freeciv server segfaults when client connect with new bind-libs
Freeciv server segfaults when client connect with new bind-libs
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
7
All All
medium Severity low
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
:
: 150288 254221 254238 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-25 18:23 EDT by Henning Norén
Modified: 2013-04-30 19:37 EDT (History)
5 users (show)

See Also:
Fixed In Version: 9.4.2-0.3.b1.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-07 13:20:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gdb stack trace (57.46 KB, application/x-gzip)
2007-08-25 18:23 EDT, Henning Norén
no flags Details
complete strace output of the crash (8.17 KB, application/x-gzip)
2007-08-25 18:25 EDT, Henning Norén
no flags Details

  None (edit)
Description Henning Norén 2007-08-25 18:23:45 EDT
Description of problem:
Starting with the latest bind-libs, civserver always crashes when a client
connects. 
Civserver works just fine when reverting back to the last release of bind-libs
and bind-utils (9.4.1-9.P1.fc7)

Version-Release number of selected component (if applicable):
bind-libs-9.4.2-0.1.b1.fc7
bind-utils-9.4.2-0.1.b1.fc7
bind-debuginfo-9.4.2-0.1.b1.fc7
freeciv-2.0.9-1.fc7
freeciv-debuginfo-2.0.9-1.fc7

How reproducible:
Always

Steps to Reproduce:
1. run civclient and try to start a new game
or, for easier debugging:
1. run civserver
2. run civclient -a -s localhost -p 5555
  
Actual results:
civserver segfaults
Comment 1 Henning Norén 2007-08-25 18:23:45 EDT
Created attachment 172661 [details]
gdb stack trace
Comment 2 Henning Norén 2007-08-25 18:25:43 EDT
Created attachment 172681 [details]
complete strace output of the crash
Comment 3 Adam Tkac 2007-08-29 02:26:49 EDT
*** Bug 254238 has been marked as a duplicate of this bug. ***
Comment 4 Adam Tkac 2007-08-29 02:27:04 EDT
*** Bug 254221 has been marked as a duplicate of this bug. ***
Comment 5 Adam Tkac 2007-08-29 02:38:28 EDT
could anyone test
http://people.redhat.com/atkac/bind/bind-9.4.2-0.1.1.b1.fc7.src.rpm and tell me
if problem still exists, please?

Adam
Comment 6 Henning Norén 2007-08-29 12:25:34 EDT
Hi Adam,

I just tried reproducing with the rpms built from the srpm above and it seems
like it is fixed.

Sincerely,
Henning
Comment 7 Kevin Fenzi 2007-08-29 13:55:45 EDT
This version also solves the problem twinkle was having. 
Comment 8 Adam Tkac 2007-08-30 10:48:24 EDT
*** Bug 150288 has been marked as a duplicate of this bug. ***
Comment 9 Fedora Update System 2007-09-04 18:06:14 EDT
bind-9.4.2-0.2.b1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2007-09-07 13:20:42 EDT
bind-9.4.2-0.3.b1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2007-10-24 03:02:03 EDT
bind-9.4.2-0.2.b1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.