Bug 25434 - Installer reported possible bug during Anaconda(?) install
Summary: Installer reported possible bug during Anaconda(?) install
Status: CLOSED DUPLICATE of bug 21904
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-01-31 23:23 UTC by psmbugzilla
Modified: 2007-04-18 16:31 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-01 16:41:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description psmbugzilla 2001-01-31 23:23:55 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows 98)


This error was kicked out by the installer, which told me that it is 
likely a bug, and to report it via bugzilla. Error text follows:

Traceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", 
line 20, in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1664, in 
doInstall
    self.x.write (self.instPath + "/etc/X11")
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/xf86config.py", line 
895, in write
    config4 = self.Version4Config ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/xf86config.py", line 
1173, in Version4Config
    info["enableVariant"] = ""
NameError: info

Local variables in innermost frame:
data: {'screenModes': '\012\011Subsection "Display"\012        
\011Depth       24\012                Modes       "1280x1024" \012
\011EndSubsection\012', 'videoRam': '', 'pex5Mod': '\012
\011Load "pex5"', 'XkbModel': 'dell101', 'monitorVert': '48.0-
120.0', 'mouseDevice': 'psaux', 'cardVendor': 'ATI 
Mach64', 'cardsOptions': '\011# no known 
options', 'XkbRules': 'xfree86', 'cardBoardName': 'ATI 
Mach64', 'ia64Mods': '', 'XkbLayout': 'us', 'nonSparcMods': '\012
\011Load "fbdevhw"', 'defaultDepth': '', 'XkbOptions': '', 'cardID': 'ATI 
Mach64', 'emulate3': 'no', 'enableOptions': '#', 'monitorHoriz': '30.0-
96.0', 'enableVariant': '#', 'XkbVariant': 'nodeadkeys', 'mouseProto': 'PS/
2', 'files': '\012# The location of the RGB database.  Note, this is the 
name of the\012# file minus the extension (like ".txt" or ".db").  There 
is normally\012# no need to change the default.\012\012    
RgbPath\011"/usr/X11R6/lib/X11/rgb"\012\012# Multiple FontPath entries are 
allowed (they are concatenated together)\012# By default, Red Hat 6.0 and 
later now use a font server independent of\012# the X server to render 
fonts.\012\012    FontPath   "/usr/X11R6/lib/X11/fonts/TrueType"\012    
FontPath   "unix/:7100"\012'}
self: <xf86config.XF86Config instance at 829c498>
maxdepth: 24
res: 1280x1024
test: 0
mouseProto: PS/2
emulate3: no
modes: ['1280x1024']
depth: 24
screens: 
	Subsection "Display"
        	Depth       24
                Modes       "1280x1024" 
	EndSubsection


ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>


Reproducible: Didn't try

Comment 1 Michael Fulbright 2001-02-01 16:41:38 UTC

*** This bug has been marked as a duplicate of 21904 ***


Note You need to log in before you can comment on or make changes to this bug.