Bug 25453 - typo in /etc/rc.d/init.d/network prevents eth0 from coming up at boot.
Summary: typo in /etc/rc.d/init.d/network prevents eth0 from coming up at boot.
Status: CLOSED DUPLICATE of bug 24674
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-01 09:44 UTC by Max Eper
Modified: 2014-03-17 02:18 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-01 09:44:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Max Eper 2001-02-01 09:44:34 UTC
[root@oldcow i386]# rpm -qf /etc/rc.d/init.d/network
initscripts-5.55-1

Missing pipe near end of line 38 breaks the script - I ran it piece by 
piece from command line to find it.  Then $interfaces doesn't get set 
to 'eth0', so eth0 isn't brought up.

interfaces=`ls ifcfg* | egrep -v '(ifcfg-lo|:|rpmsave|rpmorig|rpmnew)' | \
	    egrep -v '(~|\.bak)$' \

should be:

interfaces=`ls ifcfg* | egrep -v '(ifcfg-lo|:|rpmsave|rpmorig|rpmnew)' | \
	    egrep -v '(~|\.bak)$'  | \

Hey, I learned a lot figuring this out.

Comment 1 Bill Nottingham 2001-02-01 16:32:59 UTC

*** This bug has been marked as a duplicate of 24674 ***


Note You need to log in before you can comment on or make changes to this bug.