Bug 254661 - [drive side detect failure pata_marvell] assign UDMA33 on UDMA66 peripheral with 80-ribbon cable
[drive side detect failure pata_marvell] assign UDMA33 on UDMA66 peripheral w...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Alan Cox
Fedora Extras Quality Assurance
:
: 384671 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-26 00:00 EDT by xavier
Modified: 2008-05-14 07:20 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-14 07:20:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci and dmesg (67.69 KB, text/plain)
2007-09-30 11:45 EDT, xavier
no flags Details
Output of lscpi -vvxxx (39.32 KB, text/plain)
2007-09-30 12:26 EDT, Christopher Brown
no flags Details
Output of dmesg (28.37 KB, text/plain)
2007-09-30 12:27 EDT, Christopher Brown
no flags Details
mattg: 'dmesg' output (28.91 KB, text/plain)
2007-11-17 17:33 EST, mattg
no flags Details
mattg: 'lspci -vvxxx' output (42.48 KB, text/plain)
2007-11-17 17:35 EST, mattg
no flags Details
mattg 2.6.24 test 'dmesg' output (31.58 KB, text/plain)
2008-01-16 13:02 EST, mattg
no flags Details
mattg 2.6.24 test 'lspci -vvxxx' output (47.01 KB, text/plain)
2008-01-16 13:04 EST, mattg
no flags Details

  None (edit)
Description xavier 2007-08-26 00:00:17 EDT
Description of problem:

1)
In the Intel motherboard DG965WH the pata_marvell assign UDMA33 on "SONY DVD RW
DW-G120A, MYS6, max UDMA/66" with 80-ribbon cable.

2)
The chipset marvell is "Marvell Technology Group Ltd. 88SE6101 single-port
PATA133 interface (rev b1) 11ab:6101" <--- lspci and the Fedora7 identifies it
like udma100 !!!

DMESG part:
scsi4 : pata_marvell
scsi5 : pata_marvell
ata5: PATA max UDMA/100 cmd 0x0000000000011018 ctl 0x0000000000011026 bmdma
0x0000000000011000 irq 17
ata6: DUMMY
BAR5:00:00 01:7F 02:22 03:CA 04:00 05:00 06:00 07:00 08:00 09:00 0A:00 0B:00
0C:01 0D:00 0E:00 0F:00
ata5.01: ATAPI: SONY    DVD RW DW-G120A, MYS6, max UDMA/66
ata5.01: limited to UDMA/33 due to 40-wire cable
ata5.01: configured for UDMA/33
scsi 4:0:1:0: CD-ROM            SONY     DVD RW DW-G120A  MYS6 PQ: 0 ANSI: 5


Actual results:

PATA max UDMA/100

limited to UDMA/33 due to 40-wire cable
configured for UDMA/33


Expected results:

PATA max UDMA/133

configured for UDMA/66


Additional info:
Comment 1 xavier 2007-08-26 15:51:32 EDT
Ubuntu 7,04 is the same version of pata_marvell 0.1.4 but 32 bits and detects
and assigns the UDMA66 well

DMESG Ubuntu:

ata1: PATA max UDMA/100 cmd 0x00011018 ctl 0x00011026 bmdma 0x00011000 irq 16
scsi0 : pata_marvell
BAR5:00:00 01:7F 02:22 03:CA 04:00 05:00 06:00 07:00 08:00 09:00 0A:00 0B:00
0C:01 0D:00 0E:00 0F:00 
ATA: abnormal status 0x7F on port 0x0001101f
ATA: abnormal status 0x7F on port 0x0001101f
ata1.01: ATAPI, max UDMA/66
ata1.01: configured for UDMA/66
scsi 0:0:1:0: CD-ROM            SONY     DVD RW DW-G120A  MYS6 PQ: 0 ANSI: 5
Comment 2 xavier 2007-08-26 16:59:50 EDT
Ubuntu 7,04 64 bits the same version of pata_marvell 0.1.4 and detects
and assigns the UDMA66 well
Comment 3 Christopher Brown 2007-09-30 08:53:37 EDT
Hello,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug and will try and assist you in resolving it if I can.

There hasn't been much activity on this bug for a while. Could you tell me if
you are still having problems with the latest kernel?

If the problem no longer exists then please close this bug or I'll do so in a
few days if there is no additional information lodged.
Comment 4 xavier 2007-09-30 10:10:19 EDT
Hello, thanks for your interest.

The bug continues taking place with kernel 2.6.22.9-91.fc7 in x86-64
In 32 bits version i dont know if continues taking place.
Comment 5 Christopher Brown 2007-09-30 11:26:11 EDT
Thanks for the feedback xavier. Could you run the two following commands:

# lspci -vvxxx

dmesg

and post back as an attachment of type text/plain. I will then assign this to
the relevant maintainer who is best placed to review it.

Thanks
Chris
Comment 6 xavier 2007-09-30 11:45:29 EDT
Created attachment 211801 [details]
lspci and dmesg
Comment 7 Christopher Brown 2007-09-30 12:26:38 EDT
Created attachment 211841 [details]
Output of lscpi -vvxxx

Separating info for convenience. Please post any output separately in future.
Comment 8 Christopher Brown 2007-09-30 12:27:15 EDT
Created attachment 211851 [details]
Output of dmesg
Comment 9 xavier 2007-10-03 14:24:48 EDT
If I connect a hard disk the udma configuration is well.
The bug is only for the DVD unit
Comment 10 xavier 2007-10-03 14:38:25 EDT
bug takes place independently that dvd is master or slave
Comment 11 Alan Cox 2007-10-03 16:17:17 EDT
Your hardware says that the channel is 40 wire. The status is read from the
devices on the bus.

We've fixed a couple of cases where the probing was problematic but that would
only account for master/slave combinations. If just the DVD triggers it then it
appears to be a drive bug or some kind of detection incompatibility in the hardware

(older libata didn't do cable detect right so may well simply not have noticed this)
Comment 12 xavier 2007-11-01 12:13:08 EDT
With hard disk master and DVD slave:

scsi6 : pata_marvell
scsi7 : pata_marvell
ata7: PATA max UDMA/100 cmd 0x0000000000011018 ctl 0x0000000000011026 bmdma
0x0000000000011000 irq 17
ata8: DUMMY
BAR5:00:00 01:7F 02:22 03:CA 04:00 05:00 06:00 07:00 08:00 09:00 0A:00 0B:00
0C:01 0D:00 0E:00 0F:00
ata7.00: ATA-6: ST3120022A, 3.76, max UDMA/100
ata7.00: 234441648 sectors, multi 16: LBA48
ata7.01: ATAPI: SONY    DVD RW DW-G120A, MYS6, max UDMA/66
ata7.01: limited to UDMA/33 due to 40-wire cable
ata7.00: configured for UDMA/100
ata7.01: configured for UDMA/33
Comment 13 mattg 2007-11-15 11:06:09 EST
*** Bug 384671 has been marked as a duplicate of this bug. ***
Comment 14 mattg 2007-11-17 17:33:27 EST
Created attachment 262531 [details]
mattg: 'dmesg' output
Comment 15 mattg 2007-11-17 17:35:35 EST
Created attachment 262551 [details]
mattg: 'lspci -vvxxx' output

As the opener of dupe bug #384671 under Fedora 8, I'm attaching the output of
my 'dmesg' and 'lspci -vvxxx'.
Comment 16 Christopher Brown 2008-01-13 13:33:03 EST
Hello folks,

Any update on this? Are you still experiencing the issue or has it been resolved
in an update? You might want to test and report with 2.6.24 when it arrives as
Alan has indicated there have been some fixes in cable detection, though I do
not know when these were implemented.
Comment 17 mattg 2008-01-14 10:00:55 EST
I am currently still seeing the same issue under 2.6.23.9-85.fc8, but once
2.6.24 is released I will check again and post an update here.

FWIW, UDMA/33 seems fast enough for my burning needs, so this isn't too critical
in my eyes.  (My burning problems which led me to this bug turned out to be
caused instead by hald-addon-storage polling the drive.)
Comment 18 mattg 2008-01-16 13:02:41 EST
Created attachment 291871 [details]
mattg 2.6.24 test 'dmesg' output

Behavior under test 2.6.24 kernel seems to be the same.  I'll attach new output
of dmesg and lspci -vvxxx.


# uname -a
Linux localhost 2.6.24-0.150.rc7.git4.fc9 #1 SMP Sat Jan 12 11:10:27 EST 2008
i686 i686 i386 GNU/Linux

# grep -C12 LITE /var/log/messages |cut -d" " -f5-
kernel: sd 5:0:0:0: [sdf] Write cache: enabled, read cache: enabled, doesn't
support DPO or FUA
kernel: sd 5:0:0:0: [sdf] 976773168 512-byte hardware sectors (500108 MB)
kernel: sd 5:0:0:0: [sdf] Write Protect is off
kernel: sd 5:0:0:0: [sdf] Write cache: enabled, read cache: enabled, doesn't
support DPO or FUA
kernel:  sdf: unknown partition table
kernel: sd 5:0:0:0: [sdf] Attached SCSI disk
kernel: insmod used greatest stack depth: 632 bytes left
kernel: ACPI: PCI Interrupt 0000:02:00.0[A] -> GSI 17 (level, low) -> IRQ 16
kernel: scsi6 : pata_marvell
kernel: scsi7 : pata_marvell
kernel: ata7: PATA max UDMA/100 cmd 0x2018 ctl 0x2024 bmdma 0x2000 irq 16
kernel: ata8: DUMMY
kernel: BAR5:00:00 01:7F 02:22 03:CA 04:00 05:00 06:00 07:00 08:00 09:00 0A:00
0B:00 0C:01 0D:00 0E:00 0F:00
kernel: ata7.00: ATAPI: LITE-ON DVDRW LH-20A1P, KL05, max UDMA/66
kernel: ata7.00: limited to UDMA/33 due to 40-wire cable
kernel: ata7.00: configured for UDMA/33
kernel: scsi 6:0:0:0: CD-ROM		LITE-ON  DVDRW LH-20A1P   KL05 PQ: 0
ANSI: 5
kernel: kjournald starting.  Commit interval 5 seconds
kernel: EXT3-fs: mounted filesystem with ordered data mode.
kernel: sd 0:0:0:0: Attached scsi generic sg0 type 0
kernel: sd 1:0:0:0: Attached scsi generic sg1 type 0
kernel: sd 2:0:0:0: Attached scsi generic sg2 type 0
kernel: sd 3:0:0:0: Attached scsi generic sg3 type 0
kernel: sd 4:0:0:0: Attached scsi generic sg4 type 0
kernel: sd 5:0:0:0: Attached scsi generic sg5 type 0
kernel: scsi 6:0:0:0: Attached scsi generic sg6 type 5
kernel: Driver 'sr' needs updating - please use bus_type methods
kernel: sr0: scsi3-mmc drive: 125x/125x writer dvd-ram cd/rw xa/form2 cdda tray

kernel: Uniform CD-ROM driver Revision: 3.20
kernel: [drm] Initialized drm 1.1.0 20060810
Comment 19 mattg 2008-01-16 13:04:19 EST
Created attachment 291872 [details]
mattg 2.6.24 test 'lspci -vvxxx' output
Comment 20 Christopher Brown 2008-01-16 14:42:49 EST
You might want to check for a firmware upgrade if you're comfortable doing one.
The following might be relevant to your drive...

http://us.liteonit.com/us/index.php?option=com_wrapper&Itemid=153
Comment 21 Alan Cox 2008-02-13 10:44:30 EST
Should be fixed in current  latest -mm tree, so hopefully will percolate into
base kernel 2.6.25/6 at some point
Comment 22 Alan Cox 2008-05-14 07:20:59 EDT
Now upstream

Note You need to log in before you can comment on or make changes to this bug.