Bug 384671 - Incorrect ATAPI 40-wire cable detection for IDE optical drive
Incorrect ATAPI 40-wire cable detection for IDE optical drive
Status: CLOSED DUPLICATE of bug 254661
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i686 Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-11-15 09:35 EST by mattg
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-11-15 11:06:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description mattg 2007-11-15 09:35:50 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv: Gecko/20071025 Firefox/

Description of problem:
In Fedora 8, during bootup the kernel incorrectly detects a 40-wire IDE cable for my DVD-RW drive, a Lite-On LH-20A1P.  The drive supports UDMA/66, but even with an 80-wire IDE cable (I've tried two 80-wire cables), the kernel reports that the transfer speed is limited to UDMA/33 due to a 40-wire cable.

The motherboard is an Intel DG965WH, which apparently uses a Marvell parallel IDE chip.

An excerpt from /var/log/messages:

 kernel: scsi6 : pata_marvell
 kernel: scsi7 : pata_marvell
 kernel: ata7: PATA max UDMA/100 cmd 0x00012018 ctl 0x00012026 bmdma 0x00012000 irq 16
 kernel: ata8: DUMMY
 kernel: BAR5:00:00 01:7F 02:22 03:CA 04:00 05:00 06:00 07:00 08:00 09:00 0A:00 0B:00 0C:01 0D:00 0E:00 0F:00
 kernel: ata7.00: ATAPI: LITE-ON DVDRW LH-20A1P, KL05, max UDMA/66
 kernel: ata7.00: limited to UDMA/33 due to 40-wire cable
 kernel: ata7.00: configured for UDMA/33
 kernel: scsi 6:0:0:0: CD-ROM            LITE-ON  DVDRW LH-20A1P   KL05 PQ: 0 ANSI: 5
 kernel: kjournald starting.  Commit interval 5 seconds
 kernel: EXT3-fs: mounted filesystem with ordered data mode.
 kernel: SELinux:  Disabled at runtime.
 kernel: audit(1195133978.431:2): selinux=0 auid=4294967295
 kernel: sd 0:0:0:0: Attached scsi generic sg0 type 0
 kernel: sd 1:0:0:0: Attached scsi generic sg1 type 0
 kernel: sd 2:0:0:0: Attached scsi generic sg2 type 0
 kernel: sd 3:0:0:0: Attached scsi generic sg3 type 0
 kernel: sd 4:0:0:0: Attached scsi generic sg4 type 0
 kernel: sd 5:0:0:0: Attached scsi generic sg5 type 0
 kernel: scsi 6:0:0:0: Attached scsi generic sg6 type 5
 kernel: sr0: scsi3-mmc drive: 48x/48x writer dvd-ram cd/rw xa/form2 cdda tray
 kernel: Uniform CD-ROM driver Revision: 3.20

This occurs with both released F8 kernels, and .

The DVD drive is jumpered to be IDE Master, and is connected to the second connector on the 18" 80-wire IDE cable (due to distance from the motherboard IDE connector).

For what it's worth, I have two of these DVD drives, and the other is in a Windows XP machine (different motherboard type), where it seems to be correctly operating at UDMA/66.  I've swapped the DVD drives with the same results on both sides.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Connect Lite-On LH-20A1P DVD-RW drive with 80-wire IDE cable to an Intel DG965WH motherboard
2. Boot Fedora 8
3. grep -A10 LH-20A1P /var/log/messages

Actual Results:
DVD drive seems to operate in UDMA/33 transfer mode

Expected Results:
DVD drive should operate in UDMA/66 mode

Additional info:
Comment 1 mattg 2007-11-15 11:06:08 EST
Sorry, I now see that this issue seems to be the same/similar to bug #254661.
I'll mark this as a dupe of that one.

*** This bug has been marked as a duplicate of 254661 ***

Note You need to log in before you can comment on or make changes to this bug.