Bug 25511 - 'LI' on reboot
'LI' on reboot
Product: Red Hat Linux
Classification: Retired
Component: lilo (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Doug Ledford
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-02-01 14:28 EST by Need Real Name
Modified: 2007-04-18 12:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-02-19 03:59:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-02-01 14:28:52 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows 98)

Installing RH7 on Dell XPSR350, 384M memory, 8G IDE, 9G SCSI, 20G IDE 
(Quantum Fireball). Want to put Linux on the 20G IDE, which RH7 identifies 
as hdb. 16MB /boot partition, ~1.5G /root, 133MB swap partitions. Choose 
to put the MBR on the /boot partition. Boot using SystemCommander (or not, 
if I shift hdb to top of boot order in BIOS, it still acts the same) and 
choose the /boot partition on the 20G drive to boot from. 'LI' appears on 
screen and hangs. Bug# 19027 mentions this, and one of the respondees says 
he changed his BIOS to mode 2. On my Dell BIOS I do not have that option. 
However, I can boot any MS-DOS product to ANY partion I choose on any of 
my 3 disk drives. I have d/l and installed LOADLIN and boot into Win98's 
config.sys and call linux from there, using loadlin.exe, but I think this 
is kinda mickey mouse. If Microsoft can make an operational boot loader 
why can't the geniuses at GNU? 

Oh yes, I tried Dell BIOS flash levels A03 and A13, got same result. 

Reproducible: Always
Steps to Reproduce:
1. Choose to install RH7 on 20G hdb
2. Use a 16MB /boot partition
3. Use a Dell XPSR BIOS - flash level A03 or A13
Comment 1 Aaron Brown 2001-02-19 03:59:44 EST
My Dell CPx also exhibits this condition, and goes a step further: after printing "LI" on the screen for about 1/4 of a second, it reboots, continuing this 
loop until I physically power the system down.

Booting with a rescue disk, modifying lilo.conf, taking out "linear" and inserting "lba32", running lilo, and rebooting fixes the problem, but we really do 
need to fix the logic anaconda uses to make it's decision.  I know there's got to be something in the BIOS we can hook into.

Others are doing it.  We can do it.
Comment 2 Jeremy Katz 2002-06-04 02:15:22 EDT
Unfortunately, the bios doesn't always give the proper information.  We always
give you the option of manually enabling the option in newer releases, though
and do a better job of detecting it by default.

Note You need to log in before you can comment on or make changes to this bug.