Bug 255521 - no sound card driver (feature request)
no sound card driver (feature request)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
: 274611 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-26 18:10 EDT by Farzad Ghanei
Modified: 2008-01-04 15:01 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.6.23.1-36.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-04 15:01:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
a zipped log file. (7.40 KB, application/zip)
2007-08-28 16:40 EDT, Farzad Ghanei
no flags Details
unzipped dmesg for convenience (24.02 KB, text/plain)
2007-09-30 08:55 EDT, Christopher Brown
no flags Details
text file contains output of lspsi command (44.50 KB, text/plain)
2007-09-30 16:47 EDT, Farzad Ghanei
no flags Details
text file contains the output of dmesg command (27.08 KB, text/plain)
2007-10-01 16:12 EDT, Farzad Ghanei
no flags Details
text file contains output of lsmod command (3.84 KB, text/plain)
2007-10-01 16:13 EDT, Farzad Ghanei
no flags Details
scsconfig.log (52.70 KB, text/plain)
2007-10-07 15:56 EDT, Farzad Ghanei
no flags Details
scsrun.log (225 bytes, text/plain)
2007-10-07 15:59 EDT, Farzad Ghanei
no flags Details
system-config-soundcar > scrun.log (2.6.23.1-36.fc8, installed alsa-plugins-pulseaudio) (196 bytes, application/octet-stream)
2007-10-29 17:27 EDT, Farzad Ghanei
no flags Details
system-config-soundcar > scsconfig.log (2.6.23.1-36.fc8, installed alsa-plugins-pulseaudio) (55.13 KB, application/octet-stream)
2007-10-29 17:28 EDT, Farzad Ghanei
no flags Details

  None (edit)
Description Farzad Ghanei 2007-08-26 18:10:55 EDT
fc7 does not recognize the "3D Sound Blaster Pro compatible sound 16 bit 
integrated" soundcard (used in HP pavilion 6560en laptops):
laptop specifications:
http://h10025.www1.hp.com/ewfrf/wc/
document?docname=c01113145&lc=en&cc=us&dlc=en&product=3466860&rule=32283&lang=en

the sound card is mute and no sound is played. almost everything else works 
just fine (even the infra red remote), but not the sound.
Comment 1 Chuck Ebbert 2007-08-28 15:28:06 EDT
Please post the contents of /var/log/dmesg after booting.
Comment 2 Farzad Ghanei 2007-08-28 16:40:32 EDT
Created attachment 177361 [details]
a zipped log file.
Comment 3 Christopher Brown 2007-09-30 08:55:40 EDT
Created attachment 211711 [details]
unzipped dmesg for convenience

Unzipping dmesg, please don't compress attachments.
Comment 4 Christopher Brown 2007-09-30 08:57:18 EDT
Hello,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug and will try and assist you in resolving it if I can.

There hasn't been much activity on this bug for a while. Could you tell me if
you are still having problems with the latest kernel? If you are, please could
you also attach an output for:

# lspci -vvxxx

as text/plain type to this bug.

If the problem no longer exists then please close this bug or I'll do so in a
few days if there is no additional information lodged.
Comment 5 Farzad Ghanei 2007-09-30 16:43:23 EDT
I keep updating my system every 2-3 days. Since I reported this bug, I have 
updated the kernel 2-3 times. unfortunately the problem still exists. I will 
attach the output for lspci -vvxxx right away.
thank you.
Comment 6 Farzad Ghanei 2007-09-30 16:47:16 EDT
Created attachment 211901 [details]
text file contains output of lspsi command
Comment 7 Christopher Brown 2007-09-30 17:39:38 EDT
Thanks. You have the 82801H chipset which should be driven by the standard intel
driver I believe. It is possible it is not loading on boot - could you also
attach the output from dmesg and lsmod as well so I can see what is happening
with the hardware.
Comment 8 Christopher Brown 2007-10-01 10:48:27 EDT
*** Bug 274611 has been marked as a duplicate of this bug. ***
Comment 9 Farzad Ghanei 2007-10-01 16:12:49 EDT
Created attachment 212791 [details]
text file contains the output of dmesg command
Comment 10 Farzad Ghanei 2007-10-01 16:13:36 EDT
Created attachment 212801 [details]
text file contains output of lsmod command
Comment 11 Farzad Ghanei 2007-10-01 16:19:19 EDT
this might be irrelevant information, but I'm using FC7-x86_64 on a Santarosa 
(T7300) Intel cpu.
When I turn the laptop on, the speaker's light is on. grub comes and starts the 
boot, it is still on. when the boot process starts, just before system services 
start to load, when there is a message that tells:
starting udev [ok]
the speaker's light will go.
thanks again.
Comment 12 Chuck Ebbert 2007-10-01 16:33:29 EDT
try adding this command to /etc/rc.local (or run it from a command prompt):

alsaunmute 0
Comment 13 Farzad Ghanei 2007-10-02 01:40:57 EDT
I just ran the command from bash. it didn't work (nothing happened). is there a 
difference between running it from bash, or adding it to rc.local?
Comment 14 Christopher Brown 2007-10-02 08:42:08 EDT
Yes, rc.local will run as root. So you should test as Chuck suggested and post
back. Really though this is fixed upstream I believe  - you might want to test
with a rawhide kernel or with the following Fedora 8 live cd:

http://torrent.fedoraproject.org/torrents//rawhide-i386-Live-20070925.torrent
Comment 15 Farzad Ghanei 2007-10-02 15:26:00 EDT
I added the alsaunmute 0 command to rc.local and rebooted my system. it didn't 
work. about the rawhide kernel, how may i use it without loosing my current 
system configuration and apps. can I install it on my FC7? though i will try 
the live cd and report the results asap. it's just that it will take some time 
for me to download it (128Kb/s).
Comment 16 Christopher Brown 2007-10-02 17:31:09 EDT
You can install a development kernel and it will not affect your applications
and system configuration. When you have finished testing it, you reboot, choose
the old kernel from the boot loader screen and remove the rawhide kernel.
However only do this if you are confident doing so - I do not want to put you
under any pressure. A live cd does not touch your hard drive (unless you mount
it of course) so this would be an easier way to test although I appreciate it
may take a while to download.
Comment 17 Farzad Ghanei 2007-10-03 18:19:18 EDT
I will install a development kernel on my system. could you please send me a 
link to download the rawhide kernel? well if it works, and is stable enough for 
me, i will be using it. much better than a live cd.
Comment 18 Chuck Ebbert 2007-10-03 18:31:46 EDT
as root:
 # yum --enablerepo=development --nogpgcheck update kernel
Comment 19 Farzad Ghanei 2007-10-05 03:34:56 EDT
I installed kernel.x86_64 0:2.6.23-0.217.rc9.git1.fc8 through the above 
command. the same thing happened. the sound LED on my laptop got turned off 
when the system was starting udev.
Comment 20 Christopher Brown 2007-10-05 14:27:31 EDT
You could try adding the following to /etc/modprobe.conf

options snd-hda-intel model=3stack

If this doesn't work, please can you go to Administration > Soundcard Detection
> System and generate a log, then attach to this bug. Thanks.
Comment 21 Farzad Ghanei 2007-10-07 15:53:00 EDT
I added the option above to /etc/modprobe.conf and booted my system with both 
kernels (2.6.22.9-91.fc7 #1 SMP , and kernel.x86_64 0:2.6.23-
0.217.rc9.git1.fc8). Yet there is no sound. I could not generate the logs using 
the fc8 kernel because my graphic card driver was not configured for that 
kernel, and using text interface I couldn't find out a way to generate those 
logs. but then I booted my laptop with fc7 kernel, and I got the logs. I will 
attach them here. thanks.
Comment 22 Farzad Ghanei 2007-10-07 15:56:57 EDT
Created attachment 218851 [details]
scsconfig.log
Comment 23 Farzad Ghanei 2007-10-07 15:59:34 EDT
Created attachment 218861 [details]
scsrun.log
Comment 24 Chuck Ebbert 2007-10-08 17:34:49 EDT
(In reply to comment #22)
> Created an attachment (id=218851) [edit]
> scsconfig.log
> 

Looks like it doesn't recognize the codec at all.

Comment 25 Farzad Ghanei 2007-10-10 17:18:19 EDT
what should i do now?
Comment 26 Farzad Ghanei 2007-10-27 11:53:21 EDT
is there any hope that in FC8 this problem will no longer exist?
Comment 27 Chuck Ebbert 2007-10-29 14:58:30 EDT
The latest kernels, 2.6.23.1-36 and later, contain a big sound driver update.
Can you try one of them?
Comment 28 Farzad Ghanei 2007-10-29 16:00:30 EDT
I heard about about it just an hour ago. I downloaded it from koji's website >

http://koji.fedoraproject.org/packages/kernel/2.6.23.1/36.fc8/x86_64/

and installed it. but again at the time udev is starting in the begining of the 
boot process, the sound gets mute.

I found some information about this problem in ubuntuforums where someone 
mentioned using the new kernel and running 2 scripts (downloads some packages 
from alsa project, builds kernel modules, and copies those modules into the 
right place), and some configurations, the problem will be solved.

http://ubuntuforums.org/showthread.php?p=3649187

he also named some laptop models that this procedure might be useful for, and 
my laptop model was among them (hp pavillion 6560). right now I'm trying it. I 
will report any results asap.
Comment 29 Chuck Ebbert 2007-10-29 16:11:31 EDT
(In reply to comment #28)
> 
> he also named some laptop models that this procedure might be useful for, and 
> my laptop model was among them (hp pavillion 6560). right now I'm trying it. I 
> will report any results asap.

This update includes all of that code.

Did you re-run system-config-soundcard after the kernel update?

Also, does the alsaunmute program work?

And is pulseaudio in use? (Check if the alsa-plugins-pulseaudio package is
installed.)
Comment 30 Farzad Ghanei 2007-10-29 17:25:02 EDT
I re-ran system-config-soundcard with new kernel; it did'nt work.

alsaunmute didn't work.

I installed alsa-plugins-pulseaudio and tried system-config-soundcard and 
alsaunmute again, nothing happened. no sound at all. though this package was 
installed on my system (I queried rpm), in the system-config-soundcard there is 
no sign of it. is this ok?

I will dump any information I have about my current sound system here:

kernel: 2.6.23.1-36.fc8 #1 SMP
alsa driver version: 1.0.15
alsa lib package: alsa-lib-1.0.14.fc7
alsa util package: alsa-utils-1.0.14-2.fc7
default audio card: Intel corporation 82801H (ICH8) HD audio controller
defualt pcm device: ALC268 Analog
card module: snd-hda-intel

I will upload log files generated by the system-config-soundcard after trying 
these steps here.

thanks
Comment 31 Farzad Ghanei 2007-10-29 17:27:40 EDT
Created attachment 242411 [details]
system-config-soundcar >  scrun.log (2.6.23.1-36.fc8, installed alsa-plugins-pulseaudio)
Comment 32 Farzad Ghanei 2007-10-29 17:28:30 EDT
Created attachment 242431 [details]
system-config-soundcar >  scsconfig.log (2.6.23.1-36.fc8, installed alsa-plugins-pulseaudio)
Comment 33 Farzad Ghanei 2007-11-03 16:32:14 EDT
WOW! it worked! I just turned on my laptop today, and during the boot when udev 
is starting, the sound button of my laptop turned off (as always) but turned on 
quickly. and now the sound works just fine! I tested the previous kernel 
(2.6.23-1.10.fc7), it didn't work but with the new kernel (2.6.23-1.36.fc8) it 
worked.
but a question came on my mind. the media buttons of my laptop (play, pause, 
stop, mute which is the sound indicator that used to get off, and volume 
buttons) all worked with previous kernel but the mute button which was off all 
the time. but with new kernel the change volume buttons and mute button don't 
work, but the mute button is on always. I thought there may be a problem with 
the button itself. that while it is unused (with new kernel) it allows sound to 
be played, and when it's brothers that change the volume work (with previous 
kernel) the sound is muted. I hope this is wrong, because this means that the 
bug should be changed from (no sound card) to (no mute button) and means that 
the bog is not resolved. I tried a couple of tricks to test it and they were 
wrong.
so as long as there is no kernel that supports both new improvements on alsa, 
and volume buttons, I can not be sure of it.
but thanks so much for all the effort! now I'm listening to Sting on my laptop! 
thanks for everything! you guys are greate!
Comment 34 Chuck Ebbert 2007-11-05 13:59:07 EST
You might need keyboard quirks.  See: 

http://people.freedesktop.org/~hughsient/quirk/

You will need to boot in runlevel 3 and test the keys from the console to see if
they are generating the right codes.
Comment 35 Farzad Ghanei 2007-11-05 15:42:12 EST
I didn't try the quirks website yet. I updated my laptop last night and truned 
it on now, and Hey! my volume buttons work! but the main sound button whose 
task is to mute/unmute the system and was off until the last kernel, still does 
not work. I tried the console and when I press the button, it will enter a 
tilda (~). that's cool for a new BAB (born-again-button). ;)
I'll test the quirks site and if I find something usefull, I'll write in here.
thanks.
Comment 36 Christopher Brown 2007-12-13 11:50:23 EST
Farzad,

Whats the latest on this? Did the quirks help?
Comment 37 Farzad Ghanei 2007-12-13 14:58:27 EST
I'm a little confused. I tried the quirks website. I read these information:

http://people.freedesktop.org/~hughsient/quirk/quirk-keymap-intro.html
http://people.freedesktop.org/~hughsient/quirk/quirk-keymap-scancodes.html

I undrestood the things that quirks do. but in the second page, it says there 
must be a key mapping problem in the dmesg that indicates my button does not 
work. ok?
but I tried dmesg and there was nothing related to the buttons.
There is only 1 button on my laptop that does not work, the mute/unmute button 
(which was off those bad bad days that I didn't have sound, and now is always 
on thanks to you).
I pressed this button 3-4 times, and ran the following command:

dmesg | grep -i setkeycode

nothing. so I thought maybe I searched for the wrong phrase. I ran this:

dmesg | grep -i key

there was nothing about my keyboard or stuff. just something about keyring. :)

should I do anything special now?

by the way, I downloaded Fedora 8 (took about 2 weeks :p not so fast 
connection) but I'm doing some stuff now so I needed my current system. I was 
wondering if I upgrade to fedora 8, will the soundcard still work?

I'm using kernel 2.6.23-1.36.fc8 smp test kernel now.
Comment 38 Christopher Brown 2008-01-03 18:09:07 EST
(In reply to comment #37)

As the quirks stuff really is very device specific I can't comment, save for
advising the usual support channels such as forums.
 
> by the way, I downloaded Fedora 8 (took about 2 weeks :p not so fast 
> connection) but I'm doing some stuff now so I needed my current system. I was 
> wondering if I upgrade to fedora 8, will the soundcard still work?
> 
> I'm using kernel 2.6.23-1.36.fc8 smp test kernel now.
> 

I can't guarantee that the soundcard will work but see no reason why it should
not. You can always test with a live cd however as you have indicated you are
limited by bandwidth. You might want to consider closing this bug as your
original problem is resolved by the way.

Cheers
Chris

Note You need to log in before you can comment on or make changes to this bug.