Bug 25569 - crash after formatting disk and before package installation
crash after formatting disk and before package installation
Status: CLOSED DUPLICATE of bug 19928
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-01 18:16 EST by Need Real Name
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-01 18:18:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-02-01 18:16:11 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98)


During the installation process of redhat 7.0 by using to install on a 
WIN95 FAT 32 partition, Anacona format the / volume and then report a bug 
before installing the packages: Logs included


Reproducible: Always
Steps to Reproduce:
1.choose install on a DOS partition
2.select the manual installtion
3.Select manualy package
	

Actual Results:  The graphical interface check the dependencices and start 
creating the file system, after reaching 100%, the system report a bug in 
the bug windows before installing the packages.

Expected Results:  installing the packages.

Traceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", 
line 20, in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1480, in 
doInstall
    if self.method.systemMounted (self.fstab, self.instPath, 
self.hdList.selected()):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/image.py", line 46, in 
systemMounted
    self.loopbackFile = mntPoint + fstab.filesystemSpace(mntPoint)[0][0] + 
\
IndexError: list index out of range

Local variables in innermost frame:
fstab: <fstab.GuiFstab instance at 84b9af8>
mntPoint: /mnt/sysimage
selected: [LPRng, MAKEDEV, Mesa, Mesa-devel, ORBit, ORBit-devel, SDL, 
SysVinit, XFree86, XFree86-75dpi-fonts, XFree86-Mach64, XFree86-devel, 
XFree86-libs, XFree86-tools, XFree86-twm, XFree86-xdm, XFree86-xfs, Xaw3d, 
Xaw3d-devel, Xconfigurator, anacron, apmd, ash, aspell, aspell-fr, at, 
audiofile, audiofile-devel, aumix, authconfig, autoconf, automake, 
autorun, awesfx, basesystem, bash, bc, bdflush, bind-utils, binutils, 
bison, bug-buddy, byacc, bzip2, bzip2-devel, cdda2wav, cdecl, cdp, 
cdparanoia, cdrecord, chkconfig, chkfontpath, compat-egcs, compat-egcs-
c++, compat-glibc, compat-libstdc++, console-tools, control-center, 
control-center-devel, control-panel, cpio, cpp, cproto, cracklib, cracklib-
dicts, crontabs, ctags, cvs, cyrus-sasl, db1, db1-devel, db2, db3, dev, 
dev86, dhcpcd, dia, diffstat, diffutils, dip, docbook, dosfstools, 
e2fsprogs, ed, ee, eject, emacs, emacs-X11, emacs-nox, esound, esound-
devel, expect, extace, file, filesystem, fileutils, findutils, finger, 
finger-server, flex, fortune-mod, freetype, ftp, gawk, gcc, gcc-c++, gcc-
objc, gd, gd-devel, gdb, gdbm, gdbm-devel, gdk-pixbuf, gdk-pixbuf-devel, 
gdm, gedit, gettext, gftp, ghostscript, ghostscript-fonts, gimp, gimp-
devel, glade, glib, glib-devel, glibc, glibc-devel, gmc, gmp, gnome-
applets, gnome-audio, gnome-audio-extra, gnome-core, gnome-core-devel, 
gnome-libs, gnome-libs-devel, gnome-linuxconf, gnome-media, gnome-objc, 
gnome-objc-devel, gnome-pim, gnome-pim-devel, gnome-print, gnome-users-
guide, gnome-utils, gnorpm, gnotepad+, gnupg, gpm, gpm-devel, gqview, 
grep, groff, groff-perl, gtk+, gtk+-devel, gtk-engines, gtop, guile, gv, 
gzip, hdparm,imlib, imlib-cfgeditor, imlib-devel, indent, indexhtml, 
inews, info, initscripts, ipchains, iproute, iptables, iputils, 
isapnptools, kbdconfig, kdebase, kdelibs, kdelibs-devel, kdemultimedia, 
kdenetwork, kdesupport, kdesupport-devel, kdeutils, kdevelop, kernel, 
kernel-headers, kernel-pcmcia-cs, kernel-utils, kernelcfg, kgcc, kpppload, 
krb5-devel, krb5-libs, kudzu, kudzu-devel, less, libghttp, libghttp-devel, 
libglade, libglade-devel, libgtop, libgtop-devel, libjpeg, libjpeg-devel, 
libpng, libpng-devel, librep, libstdc++, libstdc++-devel, libtermcap, 
libtermcap-devel, libtiff, libtiff-devel, libtool, libtool-libs, libungif, 
libungif-devel, libxml, libxml-devel, lilo, links, linuxconf, linuxconf-
devel, logrotate, losetup, lrzsz, ltrace, m4, magicdev, mailcap, mailx, 
make, man, man-pages, man-pages-fr, mc, memprof, metamail, mikmod, 
mingetty, minicom, mkbootdisk, mkinitrd, mkisofs, mktemp, mkxauth, 
modemtool, modutils, mount, mouseconfig, mpage, mpg123, mt-st, mtools, 
multimedia, mutt, mysql, mysql-server, ncftp, ncompress, ncurses, ncurses-
devel, ncurses4, net-tools, netcfg, netpbm, netpbm-devel, netpbm-progs, 
netscape-common, netscape-communicator, newt, newt-devel, nfs-utils, 
njamd, nmh, ntsysv, openjade, openldap, openssh, openssh-askpass, openssh-
askpass-gnome, openssh-clients, openssh-server, openssl, openssl-devel, 
pam, passwd, patch, pciutils, pciutils-devel, perl, php, php-mysql, 
pidentd, pilot-link, pilot-link-devel, pine, playmidi, playmidi-X11, 
plugger, pmake, pnm2ppa, popt, portmap, ppp, printtool, procmail, procps, 
psmisc, pspell, pump, pwdb, pygnome, pygnome-libglade, pygtk, pygtk-
libglade, python, python-devel, python-xmlrpc, pythonlib, qt, qt-devel, 
qt1x, qt1x-devel, quota, raidtools, rcs, rdate, rdist, readline, readline-
devel, redhat-logos, redhat-release, rep-gtk, rep-gtk-gnome, rep-gtk-
libglade, rhn_register, rhn_register-gnome, rhs-printfilters, rmt, 
rootfiles, rp-pppoe, rp3, rpm, rpm-build, rpm-devel, rpm-python, rsh, rsh-
server, rusers, rusers-server, rwall-server, rwho, rxvt, samba-client, 
samba-common, sane, sash, sawfish, sed, sendmail, setserial, setup, 
setuptool, sgml-common, sgml-tools, sh-utils, shadow-utils, sharutils, 
slang, slang-devel, slocate, slrn, smpeg, sndconfig, sox, stat, 
statserial, strace, stunnel, stylesheets, switchdesk, switchdesk-gnome, 
switchdesk-kde, sysklogd, sysstat, talk, talk-server, tar, tcl, tclx, 
tcp_wrappers, tcpdump, tcsh, telnet, telnet-server, termcap, tetex-fonts, 
tetex-xdvi, texinfo, textutils, tftp-server, time, timeconfig, timetool, 
tin, tix, tk, tkinter, tksysv, tmpwatch, traceroute, tree, trn, ucd-snmp, 
ucd-snmp-utils, umb-scheme, unzip, up2date, up2date-gnome, urlview, urw-
fonts, usermode, utempter, util-linux, vim-common, vim-minimal, vixie-
cron, which, whois, words, wvdial, xcdroast, xchat, xinetd, xinitrc, 
xloadimage, xmailbox, xmms, xrn, xsane, xscreensaver, xsri, xxgdb, yp-
tools, ypbind,ypserv, zip, zlib, zlib-devel]
self: <image.CdromInstallMethod instance at 83fa9c8>
p: aspell-fr
changeloop: 1

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>
Comment 1 Michael Fulbright 2001-02-01 18:18:11 EST

*** This bug has been marked as a duplicate of 19928 ***

Note You need to log in before you can comment on or make changes to this bug.