Bug 255821 - anaconda fails in current rawhide
anaconda fails in current rawhide
Status: CLOSED DUPLICATE of bug 254681
Product: Fedora
Classification: Fedora
Component: python-pyblock (Show other bugs)
rawhide
All All
medium Severity high
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F8Blocker
  Show dependency treegraph
 
Reported: 2007-08-27 01:59 EDT by Dave Airlie
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-11 13:17:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Makefile fix (711 bytes, patch)
2007-08-27 14:36 EDT, Sylvain Pasche
no flags Details | Diff

  None (edit)
Description Dave Airlie 2007-08-27 01:59:47 EDT
Description of problem:

rawhide from 27 August, anaconda-11.3.0.21-3.i386.rpm I think, I just used
diskboot.img and installed from stage2.img

I can't get the backtrace but it contains,
dmmodule.so and undefined symbol: dm_task_get_uuid
Comment 1 Orion Poplawski 2007-08-27 13:56:34 EDT
>>> import block
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/lib/python2.5/site-packages/block/__init__.py", line 20, in <module>
    import dm
ImportError: /usr/lib/python2.5/site-packages/block/dmmodule.so: undefined
symbol: dm_task_get_uuid


ldd /usr/lib/python2.5/site-packages/block/dmmodule.so
        linux-gate.so.1 =>  (0x00110000)
        libc.so.6 => /lib/libc.so.6 (0x00119000)
        /lib/ld-linux.so.2 (0xb7fbb000)
Comment 2 Sylvain Pasche 2007-08-27 14:36:42 EDT
Created attachment 174141 [details]
Makefile fix

$* expanded to nothing, so that no -lXXX flag were given to gcc.

Below is the old rule from version 0.27:

%module.so.$(VERSION) : %.o pyhelpers.o
	$(CC) $(CFLAGS) $(LDFLAGS) -Wl,-soname="$@" -o $@ $^ $(foreach
x,$(value $*_LIBS),-l$(x))
Comment 3 Sylvain Pasche 2007-08-29 17:26:19 EDT
This should be fixed now (duplicate of bug 254681)
Comment 4 Jeremy Katz 2007-09-11 13:17:53 EDT

*** This bug has been marked as a duplicate of 254681 ***

Note You need to log in before you can comment on or make changes to this bug.