Bug 25626 - Installer refuses to continue when partition does not end on boundary
Installer refuses to continue when partition does not end on boundary
Status: CLOSED DUPLICATE of bug 25747
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-02 01:23 EST by Randy Dees
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-02 01:23:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Randy Dees 2001-02-02 01:23:47 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (X11; U; Linux 2.2.17-21mdk i686)


On my HP Pavilion N3350 laptop, the manufacturers tools creates a type 84
hidden partition as /dev/hda1 which starts at sector 2 and according to
lilo ends at 36,0,something instead of 36,255,something.   This partition
is used for the sleep-to-disk function, which works just fine under both
Windows and Linux.

In custom installer mode,  where the disk does not get redone according to
Red Hat standards,  the installer detects that the partition does not end
on a cylinder boundary and refuses to continue.  I have the options of
retry and skip disk.  Retry finds the same problem and skip disk leads to a
reboot of the system.

Reproducible: Always
Steps to Reproduce:
Partition a disk with a partition that does not end on a cylinder boundary.

1.  Boot into installer
2.  Select custom installation
3.  Installer will fail without offering any method of fixing the problem.
	

Actual Results:  Installer failed.

Expected Results:  No other distribution installer, including Red Hat 7.0,
cares that I have this partition at the beginning of the disk.  I see no
reason to introduce an addtional restriction that is likely to affect other
people with laptops.  If you must introduce this restriction, at least
offer the advanced user a method of fixing the problem with fdisk.

To fix the problem and install anyway, I booted back into my existing linux
distribution and ran fdisk.  I changed the partition to end at the end of
the cylinder and re-verified that suspend-to-disk still worked.  Since it
did, I went on and installed the beta.

I recommend that you remove this check from the installer.  Make it a
warning if you like, and if you must have the check then offer to allow the
user to fix.  I could not even readily run fdisk from the command prompt on
the second console because the /dev/hda device does not exist there.  Sure,
I could create it with mknod, but that's a real pain when building a
system.
Comment 1 Glen Foster 2001-02-02 17:20:27 EST

*** This bug has been marked as a duplicate of 25747 ***
Comment 2 Randy Dees 2001-02-04 21:41:51 EST
Oh, goodie.  This is a duplicate of another bug (with a higher number, no less)
which I cannot see (lack of permission) and cannot even find on a search for all
problems with Fisher.

I'd open a bug against either bugzilla or your process but don't feel like
putting my time in for this kind of response.

Note You need to log in before you can comment on or make changes to this bug.