Bug 25747 - partitions ending on odd cylinders block installation
partitions ending on odd cylinders block installation
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
: 25626 25746 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-02 13:48 EST by Daniel Morris
Modified: 2007-04-18 12:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-17 15:24:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Morris 2001-02-02 13:48:37 EST
I've tried installing FIsher onto a Dell 420, single proc, 128 Mb, 2xIDE
drives.

Booting from CD, graphical installations die for Worksation and Custom as
installer
reports "An error occurred reading the partition table for the block device
hda. The error was:
Partition(s) do not end on cylinder boundaries"

Same happens for hdb, finally it complains that no valid devices were found
and the 
system reboots once I click the OK button.

The previous installation was Florence, booting into that I've listed the
partition tables:

[danielm@mouth floppy]$ cat hda_list 
kernel version 132096

Disk /dev/hda: 16 heads, 63 sectors, 19386 cylinders
Units = cylinders of 1008 * 512 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/hda1   *         1        33     16600+  83  Linux
/dev/hda2            34     19386   9753912    5  Extended
/dev/hda5            34     18865   9491296+  83  Linux
[danielm@mouth floppy]$ cat hdb_list 
kernel version 132096

Disk /dev/hdb: 16 heads, 63 sectors, 19386 cylinders
Units = cylinders of 1008 * 512 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/hdb1   *         1     16758   8446000+  83  Linux
/dev/hdb2         16759     19386   1324512    5  Extended
/dev/hdb5         16759     17279    262552+  83  Linux
/dev/hdb6         17280     17800    262552+  83  Linux
/dev/hdb7         17801     18321    262552+  82  Linux swap

As the system isn't critical, I can repeat any tests you'd like.
If you have two copies of this bug, then Netscape did really submit it
before
disappearing on me!

 Daniel
Comment 1 Michael Fulbright 2001-02-02 13:57:42 EST
Please boot into the Fisher installer until you see the screen that asks you
what kind of installation/upgrade you want, switch to VC2, then enter

mknod /tmp/hda
fdisk -l /tmp/hda
mknod /tmp/hdb
fdisk -l /tmp/hdb

And send me the fdisk output.
Comment 2 Michael Fulbright 2001-02-02 13:58:12 EST
*** Bug 25746 has been marked as a duplicate of this bug. ***
Comment 3 Glen Foster 2001-02-02 17:20:23 EST
*** Bug 25626 has been marked as a duplicate of this bug. ***
Comment 4 Glen Foster 2001-02-02 18:00:36 EST
We (Red Hat) should really fix this before next release
Comment 5 Daniel Morris 2001-02-03 17:50:02 EST
Additional info as requested, 

fdisk -l /tmp/hda:

kernel version 132096

Disk /tmp/hda: 255 heads, 63 sectors, 1216 cylinders
Units = cylinders of 16065 * 512 bytes

   Device Boot    Start       End    Blocks   Id  System
/tmp/hda1   *         1         3     16600+  83  Linux
Partition 1 does not end on cylinder boundary:
     phys=(32, 15, 63) should be (32, 254, 63)
/tmp/hda2             3      1217   9753912    5  Extended
Partition 2 does not end on cylinder boundary:
     phys=(1023, 15, 63) should be (1023, 254, 63)
/tmp/hda5             3      1184   9491296+  83  Linux


fdisk -l /tmp/hdb
kernel version 132096

Disk /tmp/hdb: 255 heads, 63 sectors, 1216 cylinders
Units = cylinders of 16065 * 512 bytes

   Device Boot    Start       End    Blocks   Id  System
/tmp/hdb1   *         1      1052   8446000+  83  Linux
Partition 1 does not end on cylinder boundary:
     phys=(1023, 15, 63) should be (1023, 254, 63)
/tmp/hdb2          1052      1217   1324512    5  Extended
Partition 2 does not end on cylinder boundary:
     phys=(1023, 15, 63) should be (1023, 254, 63)
/tmp/hdb5          1052      1085    262552+  83  Linux
/tmp/hdb6          1085      1117    262552+  83  Linux
/tmp/hdb7          1117      1150    262552+  82  Linux swap


Let me know if you want me to try anything else.

 Daniel
Comment 6 Michael Fulbright 2001-02-06 11:38:18 EST
It does not die - it is just notifying you of a situation which needs addressing
before we can install on the system.

I have changed the message to add some more information to aid the user in
resolving the system configuration issues which are blocking the install.
Comment 7 Daniel Morris 2001-02-06 12:39:51 EST
Ok, die is perhaps the wrong word, the system detects an anomaly, 
provides an information box then gracefully reboots. This loops 
ad-infinitum as even the Server/Custom classes won't "correct" 
the partition layout.

Note the help notes:
 for Workstation says "removes any Linux-related partitions..."
 for Server says "removes ALL existing partitions on ALL drives..."
 for Custom says "it is up to you how disk space should be partitioned.."

Clearly it doesn't get as far as doing any of these!

I'll now modify the partitions myself.

 Daniel


Comment 8 Michael Fulbright 2001-02-06 14:00:49 EST
Ok I think I spoke too soon - you are suggesting that for install classes that
were going to blow EVERYTHING away anyhow, we should offer option to zero the
partition table?

Comment 9 Daniel Morris 2001-02-06 18:52:05 EST
But for those classes the installation never gets far enough to blow anything
away.

I get the warning for hda and the option to Retry or Skip Drive. I've just
tried retry 30 times and I can't get passed it. So I Skip Drive and get
same for hdb. Then the final box say "An error has occurred - no valid
devices were found on which to create new filesystems. Please check 
your hardware for the cause of this problem." The only option is OK, 
which gracefully shuts down and restarts the system.

Perhaps therefore you have to add the option to zero the partition table,
or a note to switch to a VC and manually manipulate the partition table.
Either way the potential outcome is the loss of original data.
The warning for Server installation certainly seems to suggest to me that 
EVERYTHING on all installed disks is going to be deleted.


Comment 10 Michael Fulbright 2001-02-08 15:25:37 EST
Will address in next release.
Comment 11 Andrea Borgia 2001-03-02 03:00:25 EST
Next release means Wolverine or what? I tried installing on a Compaq Deskpro where I had previously installed beta3 (ws setup), together with NT4 and I 
got the same message. Unfortunately, I have only one disk, so installer aborts.
Comment 12 John Gilmore 2001-09-27 07:53:02 EDT
This REALLY IS buggy and you REALLY SHOULD fix it, rather than close it
saying WONTFIX.  Learn something from the Cygnus team -- we built a bug
tracking system that wouldn't let engineers or tech support staff close
out a bug until the CUSTOMER agreed that it was fixed, or didn't need to be.

I have a RedHat 5.2 system which I'm trying to upgrade to 7.1 using the
CD.  When the 5.2 system was installed, due to lots of crazy machinations
due to the 5.2 kernel not being able to handle C/H/S for 16GB disk, my
partitions were created on what the disk label thinks are "not cylinder
boundaries".

When I try to upgrade using RH 7.1, I get to the "Install or Upgrade"
screen and click Upgrade and Next.  Then it pops up a box saying that
some of my partitions don't end on a cylinder boundary, and gives me
NO OPTION except to click "Skip Drive".  Then it immediately pops up
another box saying "An error has occurred - no valid devices were found
on which to create new file systems."  Again, it gives me NO OPTION
except to click OK.  (I've tried going over to the Back button and it
DOES NOT WORK when facing one of these stupid mode-full dialog boxes.)
As soon as I click OK, the whole Anaconda terminates and the system
reboots.  It appears to be DESIGNED TO DO THIS.  That's what we are
all complaining about in this bug report.

So, there are several things to fix in here:

  *  Don't make the system reboot if you can't find any disk drives!
     Just let the sysadmin pick Back and try something else.

  *  Don't complain if partitions are supposedly "misaligned".  The
     GNU Parted (version 1.4.18) manual says it quite clearly:  there
     are no constraints on where you can put Linux partitions, they
     can go at any sector on the disk, because Linux uses LBA mode.
     Lilo will also use LBA mode if you give the "linear" option in
     /etc/lilo.conf.  The whole concept of "cylinders" is meaningless
     in every modern hard disk; to fit more data on the disk, they put more
     sectors on the outer tracks than on the inner tracks, and they
     sure don't tell US where those boundaries are.  Not only Anaconda,
     but the rest of the Linux disk utilities should ignore "cylinders"
     and "heads" and just use linear addresses.


Note You need to log in before you can comment on or make changes to this bug.