Bug 25740 - installer fails under VMware
installer fails under VMware
Status: CLOSED DUPLICATE of bug 25298
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Brent Fox
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-02-02 13:00 EST by Gene Czarcinski
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-02-07 08:56:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Gene Czarcinski 2001-02-02 13:00:06 EST
I am attempting to install  beta3 (fisher) under vmware.  VMware has a
special XF86 driver/config but does support basic VGA also.  I selected a
basic install and specified I had generic VGA.  I got the following

Traceback (innermost last):
  File "/usr/bin/anaconda", line 503, in ?
     intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/text.py", line 1179, in run
     rc = apply (step[1](), step[2])
  File "var/tmp/anaconda-7.1//usr/lib/anaconda.py", line 529, in __call__
     if server:
NameError:  server

I can install RHL 7 with no problems.
Comment 1 Michael Fulbright 2001-02-02 14:02:42 EST
Installation under VMware is not supported.
Comment 2 Gene Czarcinski 2001-02-03 13:04:18 EST
It seems to me that this is a bug in anaconda  and will show up with someone
with a vga compatible card.  The new anaconda does not allow selection of a
generic card if it believes it knows the video type.
Comment 3 Michael Fulbright 2001-02-06 14:01:39 EST
Ok we can test that.

Brent does this make sense?
Comment 4 Gene Czarcinski 2001-02-07 08:56:30 EST
Another datapoint -- I was able to successfully install beta3 as a vmware guest
by specifying "unlisted" adapter and then selecting vga-16.  Install completed
and system booted fine.
Comment 5 Brent Fox 2001-02-08 23:49:36 EST
This is a dupe of 25298.  The server variable wasn't being properly initialized.
 This has already been fixed.

*** This bug has been marked as a duplicate of 25298 ***

Note You need to log in before you can comment on or make changes to this bug.