Bug 25773 - System name set to localhost.localdomain incorrectly
System name set to localhost.localdomain incorrectly
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Erik Troan
Brock Organ
Florence RC-1
:
: 25813 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-02 18:05 EST by Mark H Johnson
Modified: 2007-04-18 12:31 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-01 11:53:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark H Johnson 2001-02-02 18:05:03 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.0-0.99.11 i586)


Installed system on a machine which the DNS properly identified it
(mark.hou.us.ray.com). The installation script displayed that name -
entered OK to confirm it. After completing the install and rebooting, the
system name was "localhost.localdomain". Had to use linuxconf to reset it.

Reproducible: Sometimes
Steps to Reproduce:
1.Install system
2.Reboot after install - look at host name on X display
3.
	

Actual Results:  System name should have matched the value entered during
installation.
Did a reinstall later (had to repartition the disk) - worked the second
time. Did not do anything apparently differently.

Expected Results:  System name is set per the installation process.
Comment 1 Jeremy Katz 2001-02-03 17:43:47 EST
*** Bug 25813 has been marked as a duplicate of this bug. ***
Comment 2 Joseph Kotran 2001-02-05 15:52:32 EST
Greetings,

	I too experienced the behavior that Mark documented.  My clients use DHCP to
configure themselves.  I think that pump is not setting the hostname correctly
in /etc/hosts and /etc/sysconfig/network.

				Regards,

				Joe Kotran
Comment 3 Glen Foster 2001-02-05 17:50:27 EST
We (Red Hat) should really try hard to fix this before next release.
Comment 4 Erik Troan 2001-02-06 19:31:46 EST
Can you both send the contents of /etc/sysconfig/network-scripts ifcfg-eth0 and
/etc/sysconfig/network?
Comment 5 Tim Waugh 2001-02-08 09:57:24 EST
I see this too.  /etc/sysconfig/network:

NETWORKING=yes
HOSTNAME=localhost.localdomain

/etc/sysconfig/network-scripts/ifcfg-eth0:

DEVICE=eth0
BOOTPROTO=dhcp
ONBOOT=yes

On boot:

[root@localhost /root]# hostname
localhost.localdomain
[root@localhost /root]# service network restart
(... it succeeds ...)
[root@localhost /root]# hostname
myhostname.surrey.redhat.com

Comment 6 Tim Waugh 2001-03-01 08:19:38 EST
I've not seen this recently, but now it's a different DHCP server.  Perhaps it
was a DHCP server configuration thing?
Comment 7 Brock Organ 2001-03-01 11:43:18 EST
I couldn't reproduce the problem here in our test lab testing both the fisher
public beta and a more recent internal test tree (qa0301.0) ... :(
Comment 8 Tim Waugh 2001-03-01 11:45:04 EST
Does the DHCP server use 'use-host-decl-names on' or 'option host-name ...'? I
think it might be to do with that.
Comment 9 Tim Waugh 2001-03-01 11:53:55 EST
Hmm, I just tried an install against a DHCP server without those options but I
can't reproduce this with Wolverine.  Maybe it really is fixed already.
Comment 10 Preston Brown 2001-03-01 12:01:32 EST
We also tried to reproduce with a post-Wolverine tree, and could not.  Seems to
be fixed.
Comment 11 adam.huffman 2001-04-17 19:59:53 EDT
On a fresh 7.1 installation, a very similar problem occurred, which meant
sendmail was very slow in delivering mail.

/etc/hosts had:
127.0.0.1 my.local.fqdn my locallost.localdomaon localhost

sendmail log messages had the relay as my.local.fqdn instead of
localhost.localdomain (which it had been in Fisher and Wolverine)

When I added a line in /etc/hosts with my internal LAN address and private
hostname, sendmail started working at normal speed.

Note You need to log in before you can comment on or make changes to this bug.