Bug 25833 - Name resolution in trouble
Name resolution in trouble
Status: CLOSED DUPLICATE of bug 25437
Product: Red Hat Linux
Classification: Retired
Component: bind (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
David Lawrence
Florence RC-1
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-02 22:16 EST by Michal Jaegermann
Modified: 2007-04-18 12:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-07 10:56:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2001-02-02 22:16:38 EST
Fisher beta3 installed on K6-2 machine seems to have serious problems
with resolver libraries.   In short name resolution does not work
regardless of a content of /etc/resolv.conf and /etc/nsswitch.conf. In
particular trying to get an information from a local name server
resulted in 'nslookup' and 'dig' dumping cores.  Here is what 'file' has
to say:

core: ELF 32-bit LSB core file of 'dig' (signal 11), Intel 80386,
version 1, from 'dig'

and this is gdb on the same core file.

(gdb) where
#0  0x402def2e in __select () from /lib/libc.so.6
#1  0x4020bc84 in __DTOR_END__ () from /usr/lib/libisc.so.3
#2  0x401cca84 in pthread_start_thread (arg=0xbf3ffc00) at manager.c:274

Jakub Jelinek suggested that this may be related to #25437.  Possible
it is, but in this case an IP number of a name server in /etc/resolv.conf
is definitely valid and none of other clients on the same network
(these are various Linux, both x86 and Alpha, and Windows machines
all of them using the same server) shows any troubles with a name
resolution.

Attempts to "strace" a command like 'host slashdot.org' do not show
anything unusual and these logs make an impression that a name server
is not responding (while it is responding just fine for anybody else).
There are no troubles to 'ping' this server by its IP number and,
after its name was added to /etc/hosts on a "stricken" machine, remote
logins by name and various means (ssh, telnet, rsh) work fine without any
trace of a delay.

  Michal
  michal@harddata.com

p.s. this is filed under 'bind' because of cores from 'dig' and 'nslookup'
bug quite likely this should really be 'glibc'.
Comment 1 Glen Foster 2001-02-05 17:58:56 EST
This defect is considered MUST-FIX for Florence Release-Candidate #1
Comment 2 Henri Schlereth 2001-02-07 04:18:13 EST
I havent tried the host command yet but dig is the only one that segfaults on
me. nslookup
works for me.
Comment 3 Henri Schlereth 2001-02-07 10:56:48 EST
Rawhide version 9.1.0-0.4 exhibts same problems.
Comment 4 Bernhard Rosenkraenzer 2001-02-07 11:01:08 EST

*** This bug has been marked as a duplicate of 25437 ***

Note You need to log in before you can comment on or make changes to this bug.