Bug 25437 - Host Utility - invalid nameserver
Host Utility - invalid nameserver
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
David Lawrence
Florence Gold
:
: 25219 25833 29096 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-31 18:42 EST by Thornton Prime
Modified: 2016-11-24 10:05 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-07 11:01:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thornton Prime 2001-01-31 18:42:09 EST
Typing in an invalid name server causes a segmentation fault:

>$host www.yahoo.com null
>Segmentation fault
Comment 1 Bernhard Rosenkraenzer 2001-02-01 08:56:14 EST
Downgrading to glibc 2.2.1-2 fixes this. (2.2.1-3 i386 causes the same crash, 
so it's not the --enable-kernel change).

Reassigning to glibc.
Comment 2 Jakub Jelinek 2001-02-01 11:38:25 EST
Should be fixed by
http://sources.redhat.com/ml/libc-hacker/2001-02/msg00000.html
It will make it into next glibc rpm build.
Comment 3 Glen Foster 2001-02-01 15:01:22 EST
We (Red Hat) should really try to fix this before the next release.
Comment 4 Bernhard Rosenkraenzer 2001-02-06 13:13:51 EST
*** Bug 25219 has been marked as a duplicate of this bug. ***
Comment 5 Bernhard Rosenkraenzer 2001-02-07 11:01:03 EST
*** Bug 25833 has been marked as a duplicate of this bug. ***
Comment 6 Jakub Jelinek 2001-02-12 04:46:43 EST
glibc-2.2.1-7 has this fixed.
Comment 7 Jakub Jelinek 2001-02-23 16:07:29 EST
*** Bug 29096 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.