Bug 259561 - child pid exit signal Segmentation fault (11)
child pid exit signal Segmentation fault (11)
Status: CLOSED DUPLICATE of bug 254241
Product: Fedora
Classification: Fedora
Component: php (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
Fedora Extras Quality Assurance
: 259521 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2007-08-28 06:08 EDT by Alexandru Ciobanu
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-08-31 17:20:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Alexandru Ciobanu 2007-08-28 06:08:22 EDT
Description of problem:
Apache exists with segmentation fault when libphp5.so is loaded.

Version-Release number of selected component (if applicable):
Apache 2.2.4 / PHP 5.2.3

How reproducible:

Steps to Reproduce:

Access apache with php module loaded.
Actual results:
child pid #pid exit signal Segmentation fault (11)

Expected results:
page load

Additional info:

child pid 5233 exit signal Segmentation fault (11), possible coredump in /tmp

# gdb httpd -c /tmp/core.5233

GNU gdb Red Hat Linux (6.6-25.fc8rh)
Copyright (C) 2006 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-redhat-linux-gnu"...
(no debugging symbols found)
Using host libthread_db library "/lib/libthread_db.so.1".

warning: Can't read pathname for load map: Input/output error.
(no debugging symbols found)
Loaded symbols for /usr/sbin/httpd
Reading symbols from /lib/libm.so.6...(no debugging symbols found)...done.
Loaded symbols for /lib/libm.so.6
Core was generated by `/usr/sbin/httpd'.
Program terminated with signal 11, Segmentation fault.
#0  0x00b478c0 in ?? () from /etc/httpd/modules/libphp5.so
(gdb) where
#0  0x00b478c0 in ?? () from /etc/httpd/modules/libphp5.so
#1  0xb7f9982d in ap_run_handler () from /usr/sbin/httpd
#2  0xb7f9d1e7 in ap_invoke_handler () from /usr/sbin/httpd
#3  0xb7fa91fe in ap_process_request () from /usr/sbin/httpd
#4  0xb7fa602f in ?? () from /usr/sbin/httpd
#5  0xb7fa180d in ap_run_process_connection () from /usr/sbin/httpd
#6  0xb7fa190c in ap_process_connection () from /usr/sbin/httpd
#7  0xb7fad512 in ?? () from /usr/sbin/httpd
#8  0xb7fad821 in ?? () from /usr/sbin/httpd
#9  0xb7fad8fa in ?? () from /usr/sbin/httpd
#10 0xb7fae45b in ap_mpm_run () from /usr/sbin/httpd
#11 0xb7f8522a in main () from /usr/sbin/httpd
Comment 1 Alexandru Ciobanu 2007-08-28 06:11:40 EDT
*** Bug 259521 has been marked as a duplicate of this bug. ***
Comment 2 John Planow 2007-08-29 17:37:06 EDT
FWIW, I reproduced the problem with debug info for PHP.  Versions are
httpd.i386-2.2.4-9 and php.i386-5.2.3-7.

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1208887536 (LWP 5389)]
0x00cf88c0 in php_handler (r=0xb948cb90)
    at /usr/src/debug/php-5.2.3/sapi/apache2handler/sapi_apache2.c:504
504             conf = ap_get_module_config(r->per_dir_config, &php5_module);
(gdb) bt
#0  0x00cf88c0 in php_handler (r=0xb948cb90)
    at /usr/src/debug/php-5.2.3/sapi/apache2handler/sapi_apache2.c:504
#1  0xb7f5a82d in ap_run_handler () from /usr/sbin/httpd
#2  0xb7f5e1e7 in ap_invoke_handler () from /usr/sbin/httpd
#3  0xb7f6a1fe in ap_process_request () from /usr/sbin/httpd
#4  0xb7f6702f in ?? () from /usr/sbin/httpd
#5  0xb7f6280d in ap_run_process_connection () from /usr/sbin/httpd
#6  0xb7f6290c in ap_process_connection () from /usr/sbin/httpd
#7  0xb7f6e512 in ?? () from /usr/sbin/httpd
#8  0xb7f6e784 in ?? () from /usr/sbin/httpd
#9  0xb7f6f699 in ap_mpm_run () from /usr/sbin/httpd
#10 0xb7f4622a in main () from /usr/sbin/httpd
Comment 3 Joe Orton 2007-08-30 04:41:41 EDT
And with php-5.2.3-8?  What does "print sizeof(request_rec)" give you in gdb?

It looks a lot like something has broken the httpd ABI.  I can't see how the
expat/db4 changes would have done this.
Comment 4 Alexandru Ciobanu 2007-08-31 16:20:35 EDT
5.2.3-8 seems to work fine so far here.
Comment 5 Dennis Jacobfeuerborn 2007-08-31 16:57:58 EDT
I upgraded to 5.2.3-8 yesterday and had the same problem. I'm back in
php-5.2.3-5 now which works fine.
Comment 6 Joe Orton 2007-08-31 17:20:36 EDT

*** This bug has been marked as a duplicate of 254241 ***

Note You need to log in before you can comment on or make changes to this bug.