Bug 26015 - Unable to run rpm -q --redhatprovides
Summary: Unable to run rpm -q --redhatprovides
Status: CLOSED DUPLICATE of bug 22911
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-05 00:47 UTC by adam.huffman
Modified: 2007-04-18 16:31 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-15 16:43:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description adam.huffman 2001-02-05 00:47:02 UTC
The cause of this problem might be that the rpm package has not been
installed correctly:

rpm -V rpm
missing    /etc/rpm/macros.db1

that's after re-installing it.

I was having problems installing the XEmacs RPM, owing to failed
dependencies, so I tried rpm -q --redhatprovides libwnn6.so.1.0
but I got the following error message:

error: cannot open Packages index using db3 - No such file or directory (2)

rpm -V rpmdb-redhat doesn't produce any errors

Comment 1 Jeff Johnson 2001-02-05 15:59:35 UTC
The 
       rpm -V rpm
       missing    /etc/rpm/macros.db1
verification is as expected, as /etc/rpm/macros.db1 is removed in %post if
already
using db3 in rpm.

Adding "--dbapi 1" will permit querying db1 databases such as what's in rpmdb.

Comment 2 adam.huffman 2001-02-06 02:31:09 UTC
It might be nice to document this.

Comment 3 Jeff Johnson 2001-02-07 17:59:58 UTC
Yes it would be nice to document, the issue is where it should be documented so
that
the information can be found.

Comment 4 Matt Wilson 2001-02-15 16:46:49 UTC

*** This bug has been marked as a duplicate of 22911 ***


Note You need to log in before you can comment on or make changes to this bug.