Bug 261021 - RN50 broken by new ati driver
RN50 broken by new ati driver
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
rawhide
All All
medium Severity low
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
: 305921 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-28 13:10 EDT by Adam Jackson
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-09 11:46:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
GDB backtrace for driver version 6.7.194 (5.00 KB, text/plain)
2007-10-02 04:30 EDT, Joachim Frieben
no flags Details
Xorg.0.log for current git snapshot of ATI driver (74.59 KB, text/plain)
2007-10-03 06:50 EDT, Joachim Frieben
no flags Details
Xorg.0.log for current git snapshot of ATI driver (83.35 KB, text/plain)
2007-10-03 07:09 EDT, Joachim Frieben
no flags Details

  None (edit)
Description Adam Jackson 2007-08-28 13:10:45 EDT
Description of problem:

Only one CRTC, makes things go boom.

restore common
restore crtc1
restore pll1
finished PLL1

Program received signal SIGSEGV, Segmentation fault.
RADEONInitDispBandwidth2 (pScrn=0x8dc7ea0, info=0x8dc8358, pixel_bytes2=4, 
    mode1=0x0, mode2=0x0) at radeon_display.c:507
507         pix_clk = mode1->Clock/1000.0;



Version-Release number of selected component (if applicable):

xorg-x11-drv-ati-6.7.192-1.fc8
Comment 1 Adam Jackson 2007-08-28 13:17:18 EDT
Not just an RN50 problem, more like a general 1-CRTC problem.  Affects Radeon
7200 too.
Comment 2 Adam Jackson 2007-09-27 10:29:18 EDT
*** Bug 305921 has been marked as a duplicate of this bug. ***
Comment 3 Joachim Frieben 2007-09-29 05:22:09 EDT
Upstream reference is https://bugs.freedesktop.org/show_bug.cgi?id=12490
Comment 4 Joachim Frieben 2007-10-02 04:30:25 EDT
Created attachment 213171 [details]
GDB backtrace for driver version 6.7.194
Comment 5 Joachim Frieben 2007-10-03 06:50:11 EDT
Created attachment 214481 [details]
Xorg.0.log for current git snapshot of ATI driver

Rebuilding xorg-x11-drv-ati-6.7.194-1.fc8 after replacing the tarball with the
current GIT snapshot (which contains corresponding changes by A. Deucher), the
X server comes up without crashing. It crashes upon switching to a virtual
console but this is still much better than before.
The downside is that the X server now ignores the 1400x1050 mode entry in
xorg.conf and defaults to 1280x1024 at 85Hz which it didn't do before. After
removing the 1400x1050 mode entry from xorg.conf, the X server still defaults
to 1280x1024 at 85Hz but at least now, the GNOME display preferences allow the
user to change the resolution to 1600x1200 at 75 Hz whereas before, only lower
resolutions were present. However, the 1400x1050 mode has disappeared
completely. This may be specific to the Fedora version though which features
some additional patches which might be relevant.
Comment 6 Joachim Frieben 2007-10-03 07:09:35 EDT
Created attachment 214491 [details]
Xorg.0.log for current git snapshot of ATI driver
Comment 7 Joachim Frieben 2007-10-04 07:19:53 EDT
The current git tree solves both the X server start-up crash and the VT switch
crash. Probably time for an update ..
Comment 8 Joachim Frieben 2007-10-05 04:32:17 EDT
Issue solved by xorg-x11-drv-ati-6.7.194-3.fc8.
Comment 9 Adam Jackson 2007-10-09 11:46:28 EDT
Closing per comment #8.

Note You need to log in before you can comment on or make changes to this bug.