Bug 305921 - X aborts after upgrade to ATI driver 6.7.191
Summary: X aborts after upgrade to ATI driver 6.7.191
Status: CLOSED DUPLICATE of bug 261021
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati   
(Show other bugs)
Version: rawhide
Hardware: i386
OS: Linux
low
low
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-09-25 19:07 UTC by Joachim Frieben
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-27 14:29:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf for ATI AIW Radeon 7200 [R100 QD] and HP A4576A (630 bytes, text/plain)
2007-09-25 19:07 UTC, Joachim Frieben
no flags Details
Xorg.0.log for ATI driver version 6.7.194 (45.28 KB, text/plain)
2007-09-25 19:12 UTC, Joachim Frieben
no flags Details
Xorg.0.log for ATI driver version 6.6.3 (62.70 KB, text/plain)
2007-09-25 19:20 UTC, Joachim Frieben
no flags Details

Description Joachim Frieben 2007-09-25 19:07:56 UTC
Description of problem:
After upgrading the ATI driver from 6.6.3-4.fc8 to 6.7.191-1.fc8, the X
server aborts upon start-up, and the monitor goes to power off mode.

Version-Release number of selected component (if applicable):
xorg-x11-drv-ati-6.7.191-1.fc8

How reproducible:
Always.

Steps to Reproduce:
1. Install xorg-x11-drv-ati-6.7.191-1.fc8 package.
2. Restart X server.
  
Actual results:
Monitor powers off.

Expected results:
X starts and graphical login panel appears.

Additional info:
- At this point, it's not possible to switch to a virtual console anymore.
  However, entering ctrl-alt-del still allows to reboot the system.
- Downgrading to xorg-x11-drv-ati-6.6.3-4.fc8 allows to recover a working
  X environment.
- All later driver versions including 6.7.194 exhibit this malfunction.
- Xorg.0.log contains a backtrace related to the crash [see attachment].
- Adding option 'NoDRI' to the driver section of xorg.conf doesn't change
  anything either.
- The monitor device is an HP A4576A 21" CRT for which a single mode
  '1400x1050' has been added to xorg.conf [otherwise, default resolution
  would be '1600x1200' which is too high]. The graphics card is an ATI
  AIW Radeon 7200 [R100 QD].

Comment 1 Joachim Frieben 2007-09-25 19:07:56 UTC
Created attachment 205901 [details]
xorg.conf for ATI AIW Radeon 7200 [R100 QD] and HP A4576A

Comment 2 Joachim Frieben 2007-09-25 19:12:49 UTC
Created attachment 205911 [details]
Xorg.0.log for ATI driver version 6.7.194

Comment 3 Joachim Frieben 2007-09-25 19:20:07 UTC
Created attachment 205921 [details]
Xorg.0.log for ATI driver version 6.6.3

Comment 4 Adam Jackson 2007-09-27 14:29:17 UTC
Yep, seen this one already.

*** This bug has been marked as a duplicate of 261021 ***

Comment 5 Joachim Frieben 2007-09-27 15:16:34 UTC
Huh? 305921 - 261021 = 44900 new bugs in just 4 weeks?


Note You need to log in before you can comment on or make changes to this bug.