Bug 262041 - doxygen segfaults while parsing valid config file
doxygen segfaults while parsing valid config file
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: doxygen (Show other bugs)
rawhide
All All
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
: Reopened
: 365771 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-28 19:46 EDT by Behdad Esfahbod
Modified: 2008-01-11 17:27 EST (History)
2 users (show)

See Also:
Fixed In Version: 1.5.4-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-11 17:02:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Behdad Esfahbod 2007-08-28 19:46:24 EDT
Happens here locally on my F7 system, as well as in koji as can be seen in this
build log:

http://koji.fedoraproject.org/koji/getfile?taskID=135571&name=build.log
Comment 1 Behdad Esfahbod 2007-11-13 16:40:39 EST
The following patch fixed it for me:

diff -up libthai-0.1.9/doc/Doxyfile.in.doxygen-segfault libthai-0.1.9/doc/Doxyfi
le.in
--- libthai-0.1.9/doc/Doxyfile.in.doxygen-segfault      2007-11-13 16:37:16.0000
00000 -0500
+++ libthai-0.1.9/doc/Doxyfile.in       2007-11-13 16:37:31.000000000 -0500
@@ -29,7 +29,6 @@ STRIP_FROM_PATH        = @top_srcdir@/in
 STRIP_FROM_INC_PATH    = @top_srcdir@/include
 SHORT_NAMES            = NO
 JAVADOC_AUTOBRIEF      = NO
-QT_AUTOBRIEF           = NO
 MULTILINE_CPP_IS_BRIEF = NO
 DETAILS_AT_TOP         = YES
 INHERIT_DOCS           = YES
@@ -50,7 +49,6 @@ EXTRACT_PRIVATE        = NO
 EXTRACT_STATIC         = NO
 EXTRACT_LOCAL_CLASSES  = YES
 EXTRACT_LOCAL_METHODS  = NO
-EXTRACT_ANON_NSPACES   = NO
 HIDE_UNDOC_MEMBERS     = YES
 HIDE_UNDOC_CLASSES     = YES
 HIDE_FRIEND_COMPOUNDS  = NO
@@ -168,7 +166,6 @@ HTML_FOOTER            = 
 HTML_STYLESHEET        = 
 HTML_ALIGN_MEMBERS     = YES
 GENERATE_HTMLHELP      = NO
-HTML_DYNAMIC_SECTIONS  = NO
 CHM_FILE               = 
 HHC_LOCATION           = 
 GENERATE_CHI           = NO
Comment 2 Hans Ulrich Niedermann 2008-01-04 12:01:27 EST
This is still open in F-8.

Supposedly fixed in doxygen 1.5.3, as remarked at bug 365771.
Comment 3 Hans Ulrich Niedermann 2008-01-04 12:01:56 EST
*** Bug 365771 has been marked as a duplicate of this bug. ***
Comment 4 Hans Ulrich Niedermann 2008-01-04 13:46:14 EST
I have just verified that the 1.5.3-1 in the F-8 branch in CVS builds on the
build servers:

http://koji.fedoraproject.org/koji/taskinfo?taskID=325264

However, in the mean time, 1.5.4 has been released.
Comment 5 Behdad Esfahbod 2008-01-04 14:47:37 EST
Re new bug title, no software should crash even when passed invalid input...
Comment 6 Fedora Update System 2008-01-11 17:02:06 EST
doxygen-1.5.4-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2008-01-11 17:27:31 EST
doxygen-1.5.4-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.