Bug 365771 - doxygen segfaults reading doxygen.cfg
doxygen segfaults reading doxygen.cfg
Status: CLOSED DUPLICATE of bug 262041
Product: Fedora
Classification: Fedora
Component: doxygen (Show other bugs)
7
All Linux
low Severity high
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-04 08:14 EST by Derek Atkins
Modified: 2008-01-04 12:01 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-04 12:01:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Configuration file that causes doxygen crash (53.33 KB, text/plain)
2007-11-04 08:14 EST, Derek Atkins
no flags Details

  None (edit)
Description Derek Atkins 2007-11-04 08:14:06 EST
Description of problem:

I recently upgraded my server from FC4 to F7.  One of my daily tasks is running
doxygen to build the nightly documentation for the project.  When I first
upgraded, doxygen was throwing a bunch of warnings every night due to deprecated
configuration parameters.  After updating the configuration doxygen now crashes
every time it's run!  Here's the stack trace:

Program received signal SIGSEGV, Segmentation fault.
QCString::assign (this=0x14, str=0x8f7e3d8 "UTF-8") at scstring.cpp:87
87        if (m_data) free(m_data);
(gdb) p m_data
Cannot access memory at address 0x14
(gdb) bt
#0  QCString::assign (this=0x14, str=0x8f7e3d8 "UTF-8") at scstring.cpp:87
#1  0x082be511 in configYYlex () at ../qtools/qcstring.h:316
#2  0x082c4582 in Config::parseString (this=0x8f69358, 
    fn=0xbf978b62 "doxygen.cfg", 
    str=0x8f8bce0 "# Doxyfile 1.5.3-20071008\n\n# This file describes the
settings to be used by the documentation system\n# doxygen (www.doxygen.org) for
a project\n#\n# All text after a hash (#) is considered a comment and"...)
    at config.l:3023
#3  0x082c4720 in Config::parse (this=0x8f69358, fn=0xbf978b62 "doxygen.cfg")
    at config.l:3031
#4  0x0806cbc4 in readConfiguration (argc=2, argv=0xbf977ba4)
    at doxygen.cpp:9066
#5  0x08049c8f in main (argc=Cannot access memory at address 0xe5d5b36
) at main.cpp:35
#6  0x002ddf70 in __libc_start_main () from /lib/libc.so.6
#7  0x08049bd1 in _start ()
(gdb) 

Version-Release number of selected component (if applicable):

doxygen-1.5.2-1.fc7

How reproducible:

Appears to be completely reproducible with the current gnucash configuration
(which I've attached).  If you want I can explain how to reconfigure the sources
out of SVN such that you'll get the current doxygen config.

Steps to Reproduce:
1. run doxygen against the config
2. watch it die a flaming death
3. cry, because your script deleted the html output already and now you have no
docs.
  
Actual results:

SEGV.  See the backtrace above.

Expected results:

Nice, pretty documentation based on our sources.

Additional info:

See attached config file.
Comment 1 Derek Atkins 2007-11-04 08:14:06 EST
Created attachment 247581 [details]
Configuration file that causes doxygen crash
Comment 2 Derek Atkins 2007-11-04 11:24:30 EST
Apparently this bug is fixed in 1.5.3:
http://bugzilla.gnome.org/show_bug.cgi?id=431763

Maybe you could push out an update?
Comment 3 Hans Ulrich Niedermann 2008-01-04 11:53:35 EST
I can confirm this with current F-8:

$ rpm -q doxygen
doxygen-1.5.2-1.fc7
$ echo "QT_AUTOBRIEF = NO" | doxygen -
Segmentation fault

I can see 1.5.3 builds in koji. Would you mind pushing those through the updates
system?
Comment 4 Hans Ulrich Niedermann 2008-01-04 12:01:55 EST

*** This bug has been marked as a duplicate of 262041 ***

Note You need to log in before you can comment on or make changes to this bug.