Bug 262361 - emacs-vm update causes emacs startup error
emacs-vm update causes emacs startup error
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: emacs-vm (Show other bugs)
7
i386 Linux
medium Severity urgent
: ---
: ---
Assigned To: Jonathan Underwood
Fedora Extras Quality Assurance
:
: 274581 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-28 23:42 EDT by Marc Schwartz
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version: 8.0.3.495-3.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-04 18:11:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Recursive diff of versions 482 and 495 (19.40 KB, application/x-research-info-systems)
2007-08-30 10:37 EDT, Marc Schwartz
no flags Details
Patch to fix error in Makefile.in (531 bytes, patch)
2007-08-30 17:08 EDT, Jonathan Underwood
no flags Details | Diff

  None (edit)
Description Marc Schwartz 2007-08-28 23:42:18 EDT
Description of problem:

With today's emacs rpm updates, the following error appears in the Messages buffer:

Loading /usr/share/emacs/site-lisp/site-start.d/ruby-mode-init.el (source)...done
Loading /usr/share/emacs/site-lisp/site-start.d/vm-mode-init.el (source)...
eval-buffer: Wrong number of arguments: #[(symbol load) "^HÃN^Y
	\235?\205^T^@Ä^HÃÅ
!	B#)\207" [symbol loads load custom-loads put purecopy] 5 718336], 1


Version-Release number of selected component (if applicable):

emacs-vm.i386 8.0.3.495-2.fc7
emacs-vm-el.i386 8.0.3.495-2.fc7


How reproducible:

Always


Steps to Reproduce:

1. Start emacs

  
Actual results:

See above


Expected results:

Proper loading of .emacs and related startup files


Additional info:

Upon attempting to do some debugging, I have noted that if one opens
'vm-mode-init.el' in /usr/share/emacs/site-lisp/site-start.d and comments line
4, which is:

  (require 'vm-autoloads)

so that it reads:

  ;;(require 'vm-autoloads)

the above errors do not appear and emacs appears to start up properly.  Thus,
there appears to be some error in one of the .el/.elc files in
/usr/share/emacs/site-lisp/vm, though I have not tracked it down to which one.
Comment 1 Jonathan Underwood 2007-08-29 16:41:41 EDT
Thanks for the report - this is a known issue upstream:

http://groups.google.co.uk/group/gnu.emacs.vm.bug/browse_thread/thread/341cd49565847957/7655101246e21b03#7655101246e21b03

alas, not yet resolved. For now, until I or someone works out the issue, I
suggest  reverting to the previous package.
Comment 2 Marc Schwartz 2007-08-29 18:45:14 EDT
Thanks for the update Jonathon.

Just as an FYI, the prior versions of the RPMS are available here:

http://koji.fedoraproject.org/koji/buildinfo?buildID=12979

I went back to emacs-vm.i386 8.0.2.482-4.fc7 and emacs-vm-el.i386 8.0.2.482-4.fc7

I have installed them and am back to running. Installing these RPMS will
overwrite vm-mode-init.el, removing the commenting of line 4.
Comment 3 Marc Schwartz 2007-08-30 10:31:37 EDT
Jonathon,

I think that I may have identified the problem and a fix.

I downloaded both sets of RPMS and used:

  rpm2cpio EACH.RPM.FILE | cpio -idv

to extract the files from all four RPMS into version specific directory trees.

I then ran a recursive 'diff' on both versions to try to identify file based
differences between the two versions.

I will attach that diff here for you.

In reviewing the diff output, I noted that one of the changes in vm-autoloads.el
was the replacement of:

  (custom-add-load 'vm 'vm-vars)

with:

  (custom-add-load 'vm-cus-load)

towards the end of the file on line 3445.

Given the comments in the thread you noted regarding 'custom-add-load' requiring
two arguments and the two arguments used in the prior version of the file, I
re-installed the version 495 rpms and edited vm-autoloads.el so that the above
line now reads:

  (custom-add-load 'vm 'vm-cus-load)

and then byte-compiled the file to update and replace the .elc file.

Emacs now loads without issuing any error messages.

It is not clear to me that this is the correct fix, but it is consistent with
the prior version and does seem to work.

I hope that this helps.
Comment 4 Marc Schwartz 2007-08-30 10:37:56 EDT
Created attachment 181181 [details]
Recursive diff of versions 482 and 495

This is a recursive diff of the files extracted from:

emacs-vm-8.0.2.482-4.fc7.i386.rpm  emacs-vm-el-8.0.2.482-4.fc7.i386.rpm

versus:

emacs-vm-8.0.3.495-2.fc7.i386.rpm  emacs-vm-el-8.0.3.495-2.fc7.i386.rpm

The potentially relevant output for:

diff -r 482/usr/share/emacs/site-lisp/vm/vm-autoloads.el
495/usr/share/emacs/site-lisp/vm/vm-autoloads.el

begins on line 176:

3439c3445
< (custom-add-load 'vm 'vm-vars)
---
> (custom-add-load 'vm-cus-load)
Comment 5 Jonathan Underwood 2007-08-30 10:40:36 EDT
OK, thanks for taking the time to analyse this. I'll push builds with this fix
later tonight.
Comment 6 Marc Schwartz 2007-08-30 10:54:46 EDT
Thanks Jonathon.  

I posted a link to this bug report in the usenet thread above.
Comment 7 Jonathan Underwood 2007-08-30 17:08:30 EDT
Created attachment 182061 [details]
Patch to fix error in Makefile.in

Actually vm-autoloads.el is a file generated at build time, and so the way to
fix this when starting from the tarball is to patch Makefile.in. The attached
patch does that.
Comment 8 Jonathan Underwood 2007-08-30 17:21:41 EDT
Have built new packages with the fix applied - you can pull them from Koji here:

http://koji.fedoraproject.org/koji/taskinfo?taskID=142282

I will push them to updates testing too (will take a couple of days to appear on
the mirrors).
Comment 9 Marc Schwartz 2007-08-30 20:15:46 EDT
Jonathon,

The new RPMS are working.

Thanks for the rapid turnaround on this.
Comment 10 Jonathan Underwood 2007-09-02 18:12:57 EDT
*** Bug 274581 has been marked as a duplicate of this bug. ***
Comment 11 Fedora Update System 2007-09-04 18:11:02 EDT
emacs-vm-8.0.3.495-3.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.