Bug 26317 - unable to change mouse type in any install mode autodetects ps/2 even if serial mouse is connected
Summary: unable to change mouse type in any install mode autodetects ps/2 even if seri...
Status: CLOSED DUPLICATE of bug 26313
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-06 16:32 UTC by Lee Cashmore
Modified: 2007-04-18 16:31 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-06 18:28:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Lee Cashmore 2001-02-06 16:32:09 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.2.16-22 i686; Nav)


When Installing there is NO way to override the autodetected mouse type.
This occurs in normal, expert modes. The machine hardware has a PS/2
controller but no PS2 mouse attached, anaconda finds this controller and
then starts the load of X windows giving no chance to change the mouse type
and within the X windows session there is no way to move between windows to
select the correct mouse type during an expert install

Reproducible: Always
Steps to Reproduce:
1. Boot from Disk or CD on a machine which has a PS2 controller with a
serial mouse attached for instance
2. Start the install process 
3. at x windows start the ps2 controller is found even thou I have a serial
mouse in. This is not a problem on new hardware where I can just plug in a
PS/2 mouse but on older machines P133 etc.. where there is PS/2
capabilities on the motherboard but no cable from the motherboard to a PS/2
port.	
	

Actual Results:  Xwindows Started but the serial mouse was not found and
ps/2 was selected which meant I could not do anymore of the install process

Expected Results:  Either the serial mouse needs to be probed for first or
the ability to select the correct mouse type needs to be added. 

Machine is a Pentuim 120 with 64 Meg ram and 4 gig Hard disk
The machine has a PS/2 controller but no cable from the motherboard to the
slots on the back of the machine to allow a PS/2 mouse to be pluged in.

Comment 1 Michael Fulbright 2001-02-06 18:28:36 UTC

*** This bug has been marked as a duplicate of 26313 ***


Note You need to log in before you can comment on or make changes to this bug.