Bug 26327 - anaconda crashing "can't open /dev/fb0" during installation
anaconda crashing "can't open /dev/fb0" during installation
Status: CLOSED DUPLICATE of bug 25514
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-06 12:25 EST by Eje Gustafsson
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-07 11:33:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eje Gustafsson 2001-02-06 12:25:07 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)


During initialization of the installer anaconda will crash and as a result 
of anaconda crashing the entire installation will crash.

Reproducible: Always
Steps to Reproduce:
1.Put CD in drive
2.Bootup from CD
3.Pick either text or gui mode (either one will give same result)
4.Waiting for the installer to start
	

Actual Results:  Anaconda crashes with error message which causes the 
installation to exit abnormally and RedHat shuts down.

Everything goes fine bootup (from CD) the blue screen comes things
happens in the background.
It starts to load GUI RedHat logo comes on screen you get a mouse cursor 
then crash back to black screen where you can read following.

Running anaconda - please wait
Probing for mouse type...
 .
 and on it goes
 skipping a few lines here with info about setting up X
 .
Using X server /usr/X11R6/bin/XF86_FBDev
can't open /dev/fb0
 - Yes it says fb0.. I double checked.
Waiting for X server to start. X server started successfully.
Traceback (innermost last):
  File "/usr/bin/anaconda", Line 500, in ?
    extraModules=extraModules, pcicController=pcicController)
  File "usr/lib/anaconda/todo.py", line 550, in __init__
    self.setFdDevice()
  File "usr/lib/anaconda/todo.py", line 592, in setFdDevice
    if not floppyDrive: Return
  NameError: floppyDrive
install exited abnormally
sending termination signals..done

I made sure during bootup that the kernel found my floppy drive.
It finds it fine and tells me my floppy drive is a 1.4M drive 

Floppy drive(s): fd0 is 1.44M
FDC 0 is a post-1991 82077

I have a ABIT KA7-100 MB the floppy is connected to the MBs floppy 
controller and is a regular 3.5" 1.4MB floppy drive. 

The same happens when doing a text installation also (except the printout 
is staircased on blue background instead of nicely printed out on a black 
background).
Comment 1 Michael Fulbright 2001-02-06 13:27:19 EST
Fix for this is given in the announcement of the fisher beta.

*** This bug has been marked as a duplicate of 25514 ***
Comment 2 Eje Gustafsson 2001-02-07 00:23:24 EST
Used the fisher-upddisk.img as suggested in 25514 gives new problem.

type in 
linux updates 
on the boot prompt
it starts up comes to blue screen ask for my updates disk put it into 
floppy drive hit OK
tells me it reads anaconda update 
continue loading. 

sees
starting anaconda..
and some other things there X starts up RH logo 
crash back to black background
now with a new error message

Traceback (innermost last):
 File "/usr/bin/anaconda", line 500, in ?
   extraModules = extraModules, pcicController = pcicController)
 File "tmp/updates/todo.py", line 561, in __init__ 
   self.setClass(instClass)
AttributeError: setClass
install exited abnormally
and we are getting shut down.
Comment 3 Eje Gustafsson 2001-02-07 00:32:28 EST
My hardware setup is...

ABIT KA7-100 MotherBoard /w Athlon 750, 2x128MB PC133 SDRAM
fd0 = standard 1.4MB Floppy
hda = 45Gig HD
hdb = unused
hdc = Mitsubitshi DVD 10x
hdd = Iomega 100MB Zip 
hde = Plexwriter 12/10/32a
hdf = unused
hdg = unused
hdh = unused

Video = Diamond Stealh S540 32MB 4x AGP video card
NIC = Netgear FA310TX 
Keyboard = PS/2 
Mouse = Logitech wheel mouseman USB /w PS/2 adapter
SoundCard = Soundblaster Live 5.1
ExtraCard = TI OHCI Compliant IEEE 1394 controller (FireWire)
Comment 4 Michael Fulbright 2001-02-07 11:33:42 EST

*** This bug has been marked as a duplicate of 25514 ***
Comment 5 Need Real Name 2001-02-22 13:26:59 EST
Quick work around is to unplug iomega zip drive

Note You need to log in before you can comment on or make changes to this bug.