Bug 26345 - no authentication agent forwarding with protocol 2.0
Summary: no authentication agent forwarding with protocol 2.0
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: openssh (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Keywords:
: 30946 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-06 19:02 UTC by Jay Berkenbilt
Modified: 2008-05-01 15:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-24 06:02:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jay Berkenbilt 2001-02-06 19:02:53 UTC
In openssh 2.3.0p1, ssh protocol 2 using DSA does not do
authentication agent forwarding even though the manual page seems to
suggest that it does.  Shamelessly ripping code (in ssh.c) from
ssh_connect and putting it into client_init didn't work, but I don't
know why because the code in client_init doesn't read responses.
Sorry -- no patch this time.  I like the fact that RedHat 7.x
configures openssh to use the more secure 2.0 protocol by default, but
I'll sure miss authentication agent forwarding until this gets
fixed...

I also reported this bug to openssh@openssh.com.

Comment 1 Jay Berkenbilt 2001-02-06 19:11:54 UTC
I got the following reply to my openssh@openssh.com bug report from Markus
Friedl <Markus.Friedl@informatik.uni-erlangen.de>:

the next release will have this feature.

-m

Hopefully that release will be soon enough or a patch can be extracted that will
fix this for now....

Comment 2 Pekka Savola 2001-02-07 01:07:14 UTC
This was merged to OpenSSH about 2.5 months ago (20001113) based on
the work by <jhuuskon@messi.uku.fi>.  Also, at the same time, remote
port forwarding for SSHv2 was added.

There have been talks about OpenSSH 2.4.0 release, but no definite plans yet.


Comment 3 Jay Berkenbilt 2001-02-24 06:02:11 UTC
I've been running openssh 2.5.1p1 for several days now.  This and other problems
are fixed.

Comment 4 Pekka Savola 2001-02-24 08:08:02 UTC
2.5.1p1 is (will be) in rawhide.


Comment 5 Pekka Savola 2001-03-07 16:01:08 UTC
*** Bug 30946 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.