Bug 30946 - Forwarding of the authentication agent connection doesn't work
Summary: Forwarding of the authentication agent connection doesn't work
Status: CLOSED DUPLICATE of bug 26345
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: openssh   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-07 14:31 UTC by Marco Colombo
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-07 14:31:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Marco Colombo 2001-03-07 14:31:41 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.2.16-3 i686)


ssh seems not to forward the connection to the ssh-agent. Since I'm using
DSA keys and protocol 2 I wonder if this is related to the forwarding
problem in #20572.

Reproducible: Always
Steps to Reproduce:
mypc$ ssh -A hostA		(pubkey auth works, no password requested)
mypc$ ssh -A hostB		(works)

once I'm on hostA, I try
hostA$ rsh hostB		(prompts for remote user's password)

Comment 1 Pekka Savola 2001-03-07 16:01:12 UTC
This feature has been added in OpenSSH 2.5.1p1, in rawhide.

*** This bug has been marked as a duplicate of 26345 ***


Note You need to log in before you can comment on or make changes to this bug.