Bug 2639 - Terminal emulation seems very broken in nxterm
Terminal emulation seems very broken in nxterm
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: ncurses (Show other bugs)
6.0
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Preston Brown
:
: 2595 3509 3993 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-05-07 15:49 EDT by Benjamin Kahn
Modified: 2008-05-01 11:37 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-01-24 16:24:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Benjamin Kahn 1999-05-07 15:49:32 EDT
Try any program which uses curses heavily and you see note
problems.  Fro example, try this:

export LESS=mdq
export PAGER=less
man tcsh

	Try browsing through the man page a bit..  Go up and down.
You should see screen garbage immediately.
Comment 1 Benjamin Kahn 1999-05-07 19:49:59 EDT
This may be a problem with ncurses...  The nxterm can view curses
programs from earlier versions of redhat.  (Ie:  I can telnet to a
redhat 5.2 box and it will be able to display the program fine.
However, if I telnet to a different redhat 6.0 box, I see the same
problem as if it were local.)
Comment 2 Michael K. Johnson 1999-05-11 14:40:59 EDT
*** Bug 2595 has been marked as a duplicate of this bug. ***

When other clients rlogin to a RedHat 6.0 system, the
xterm screen seems to have some problems. Try the
following steps:
    man ls             --- whatever manpage
    type spaces to reach the end of manpage
    (you will see EOF at the end of screen)
    quit manpage
Your display becomes black characters on white background.


------- Additional Comments From notting@redhat.com  05/06/99 10:52 -------
what are they using to rlogin? xterm/rxvt/dtterm/etc?

------- Additional Comments From xintian@cse.ogi.edu  05/06/99 20:24 -------
I am using nxterm from RedHat 5.2 version.
Comment 3 Benjamin Kahn 1999-05-29 11:53:59 EDT
Yep.  I think the common theme is that everyone copied their nxterm
from an old 5.2 install.  The reason is that the defaults for the old
nxterm were much nicer.  On a machine with the original nxterm,
everything works fine.  What has changed?
Comment 4 hawkfan 1999-06-01 16:51:59 EDT
The problem is with the fixxterm patch in the ncurses-4.2-18 rpm.
The second hunk of the patch makes the xterm entry use xterm-xf86-v333
rather than xterm-r6.  IMO this should be reverted because many xterms
accessing redhat 6.0 machines will NOT be XFree86 xterms.  XFree86
xterm users should set TERM properly if they know they will only be
using gnu ncurses terminfo definitions and want the extra
functionality.
Comment 5 hawkfan 1999-06-01 16:54:59 EDT
The problem is with the fixxterm patch in the ncurses-4.2-18 rpm.
The second hunk of the patch makes the xterm entry use xterm-xf86-v333
rather than xterm-r6.  IMO this should be reverted because many xterms
accessing redhat 6.0 machines will NOT be XFree86 xterms.  XFree86
xterm users should set TERM properly if they know they will only be
using gnu ncurses terminfo definitions and want the extra
functionality.
Comment 6 Preston Brown 1999-06-08 12:21:59 EDT
This is a ncurses issue.  We are currently trying to evaluate the
proper way to handle this.  There are some nice new features of the
new terminfo entry (color chief among them) that we would like to
provide by default (not have to make the user configure it) but we do
want to continue to "play nicely" with older terminfo entries on other
unix systems.
Comment 7 Paul J Murphy 2000-01-03 03:32:59 EST
This problem affects telnet/rlogin/ssh into RedHat 6.1 (i386) from Solaris
2.6/SPARC and Solaris 7/SPARC, using Solaris' /usr/openwin/bin/xterm displayed
on a CDE desktop session. The problem didn't exist before I upgraded from RedHat
5.2 to 6.1. _Very_ annoying if you work in a mixed environment - was nearly
enough to make me "upgrade" back to 5.2, or install Solaris 7/Intel.

It goes away if I comment out the "fixxterm" patch lines in the spec file of
ncurses-4.2-25.src.rpm, and rebuild then upgrade-install my new ncurses RPM.

My spec file can be found at http://www.murph.org/linux/ncurses.spec.
Comment 8 Paul J Murphy 2000-01-03 20:41:59 EST
After additional inspection of ncurses.spec in ncurses-4.2-25.src.rpm, I believe
that "Platform: i386" is incorrect - the fixxterm patch appears to be applied to
all platforms, so this bug should apply to all platforms, although I am unable
to verify this at present.
Comment 9 Preston Brown 2000-01-18 15:24:59 EST
*** Bug 3993 has been marked as a duplicate of this bug. ***
Comment 10 Preston Brown 2000-01-18 15:26:59 EST
*** Bug 3509 has been marked as a duplicate of this bug. ***
Comment 11 Preston Brown 2000-01-24 16:24:59 EST
fixed for next release.
Comment 12 hawkfan 2000-09-03 14:12:21 EDT
This bug is still not "fixed" in the ncurses-5.1-2 rpm.  As long as other UNIX
vendors are shipping the XC xterm code this will be a problem attributed to
RedHat Linux.  Setting TERM=xterm-r6 isn't a viable option in mixed environments
because most (all?) commercial UNIX vendors don't ship an xterm-r6 terminal
definition.  They have xterm and possibly xterm-color.

I am still getting complaints daily from our Solairs and HP/UX users about
logging into new "broken" RedHat machines.

Solution:  Change the xterm definition to use=xterm-r6 rather than
xterm-redhat.  RedHat users can set their term accordingly if they feel they
need the enhanced functionality.  In my opinion it is better to disable features
than enable bugs by default.

Note You need to log in before you can comment on or make changes to this bug.