Bug 264721 - [NetApp-N 5.2 bug] NFS client isn't setting callback address properly
Summary: [NetApp-N 5.2 bug] NFS client isn't setting callback address properly
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel   
(Show other bugs)
Version: 5.0
Hardware: All
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Steve Dickson
QA Contact: Martin Jenner
URL:
Whiteboard:
Keywords: Regression
: 412871 (view as bug list)
Depends On:
Blocks: 217208 425461
TreeView+ depends on / blocked
 
Reported: 2007-08-29 19:14 UTC by Mike Sager
Modified: 2009-03-27 22:11 UTC (History)
8 users (show)

Fixed In Version: RHBA-2008-0314
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 14:54:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2008:0314 normal SHIPPED_LIVE Updated kernel packages for Red Hat Enterprise Linux 5.2 2008-05-20 18:43:34 UTC

Description Mike Sager 2007-08-29 19:14:27 UTC
Description of problem:

When the NFS client sends a SETCLIENTID, the r_addr field contains only the 
port number.  The ip addr is null.  As a result, an NFS server can never grant 
a delegation to the NFS client.


Version-Release number of selected component (if applicable):


How reproducible:

Easy to reproduce.


Steps to Reproduce:

(while capturing a network trace)

1. Mount a filesystem using NFS v4
2. Create a file
3. Note the SETCLIENTID's r_addr field in the network trace.  There's no ip 
addr -- just a port number.
  
Actual results:


Expected results:


Additional info:

This problem was introduced into the mainline kernel in 2.6.19-rc1.  It was 
fixed in 2.6.19-rc2.  RHEL5 includes the code that has the bug but not the code 
that has the fix.  The bug is in nfs/fs/client.c.

The 2.6.19-rc2 patch that fixes it is:

commit 7d9ac06f26fe8d477c813405f1a8c7c90eecef2d
Author: J. Bruce Fields <bfields@fieldses.org>
Date:   Thu Oct 19 23:28:39 2006 -0700

    [PATCH] nfs4: initialize cl_ipaddr
    
    David forgot to do this.  I'm not sure if this is the right place to put
    it....
    
    Signed-off-by: J. Bruce Fields <bfields@citi.umich.edu>
    Signed-off-by: Trond Myklebust <Trond.Myklebust@netapp.com>
    Signed-off-by: Andrew Morton <akpm@osdl.org>
    Signed-off-by: Linus Torvalds <torvalds@osdl.org>

Another missing patch is:

commit 13bbc06af8a5f65df0f888b442e557c617cadba7
Author: Trond Myklebust <Trond.Myklebust@netapp.com>
Date:   Thu Oct 19 23:28:40 2006 -0700

    [PATCH] NFS: Fix NFSv4 callback regression
    
    The change in semantics for nfs_find_client() introduced by David breaks the
    NFSv4 callback channel.
    
    Also, replace another completely broken BUG_ON() in nfs_find_client().  In
    initialised clients, clp->cl_cons_state == 0, and callers of that function
    should in any case never want to see clients that are uninitialised.
    
    Signed-off-by: Trond Myklebust <Trond.Myklebust@netapp.com>
    Signed-off-by: Andrew Morton <akpm@osdl.org>
    Signed-off-by: Linus Torvalds <torvalds@osdl.org>

Fedora 7 has the fixes.

Comment 2 RHEL Product and Program Management 2007-08-30 12:34:06 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 4 RHEL Product and Program Management 2007-12-12 15:35:46 UTC
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.

Comment 7 Steve Dickson 2007-12-17 12:19:02 UTC
*** Bug 412871 has been marked as a duplicate of this bug. ***

Comment 8 Don Zickus 2007-12-21 20:17:48 UTC
in 2.6.18-62.el5
You can download this test kernel from http://people.redhat.com/dzickus/el5

Comment 12 errata-xmlrpc 2008-05-21 14:54:20 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0314.html



Note You need to log in before you can comment on or make changes to this bug.