Bug 264741 - run-parts error: "cat: /var/spool/anacron/cron.daily: No such file or directory"
run-parts error: "cat: /var/spool/anacron/cron.daily: No such file or directory"
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: crontabs (Show other bugs)
7
All All
medium Severity high
: ---
: ---
Assigned To: Marcela Mašláňová
Fedora Extras Quality Assurance
:
: 292621 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-29 15:20 EDT by Jordan Russell
Modified: 2007-11-30 17:12 EST (History)
7 users (show)

See Also:
Fixed In Version: 1.10-16.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-04 18:08:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jordan Russell 2007-08-29 15:20:51 EDT
Description of problem:
Since updating to crontabs-1.10-15.fc7, I now get an e-mail saying:

  cat: /var/spool/anacron/cron.daily: No such file or directory

every time run-parts runs. I don't have the anacron package installed, so
naturally that file isn't going to exist.

Version-Release number of selected component (if applicable):
crontabs-1.10-15.fc7

Steps to Reproduce:
1. Uninstall anacron.
Comment 1 Anatoly Pugachev 2007-08-30 07:57:43 EDT
confirm.
got same emails to me, after today morning 'yum -y update'

the list of packages has been updated, following:

[mator@mator 15:54:02 ~]$ rpm -qa --last | grep "Thu Aug 30 10"
rxvt-unicode-8.3-1.fc7                        Thu Aug 30 10:18:01 2007
xscreensaver-gl-extras-5.03-1.fc7             Thu Aug 30 10:17:56 2007
xscreensaver-extras-5.03-1.fc7                Thu Aug 30 10:17:50 2007
gnomebaker-0.6.1-2.fc7                        Thu Aug 30 10:17:45 2007
gdm-2.18.4-2.fc7                              Thu Aug 30 10:17:34 2007
tar-1.15.1-27.fc7                             Thu Aug 30 10:17:30 2007
elfutils-0.129-1.fc7                          Thu Aug 30 10:17:28 2007
qt-devel-3.3.8-6.fc7                          Thu Aug 30 10:17:05 2007
ntp-4.2.4p2-3.fc7                             Thu Aug 30 10:16:51 2007
kde-filesystem-3.5-13.fc7                     Thu Aug 30 10:16:49 2007
crontabs-1.10-15.fc7                          Thu Aug 30 10:16:49 2007
perl-Net-DNS-0.61-1.fc7                       Thu Aug 30 10:16:45 2007
control-center-2.18.0-20.fc7                  Thu Aug 30 10:16:05 2007
cryptsetup-luks-1.0.5-4.fc7.1                 Thu Aug 30 10:15:41 2007
liboil-0.3.12-9.fc7                           Thu Aug 30 10:15:40 2007
perl-Crypt-SSLeay-0.56-1.fc7                  Thu Aug 30 10:15:38 2007
qt-3.3.8-6.fc7                                Thu Aug 30 10:15:36 2007
elfutils-libs-0.129-1.fc7                     Thu Aug 30 10:15:34 2007
xscreensaver-base-5.03-1.fc7                  Thu Aug 30 10:15:30 2007
elfutils-libelf-0.129-1.fc7                   Thu Aug 30 10:15:08 2007

we see crontabs here, and list of "cron" packages installed:

[mator@mator 15:52:51 ~]$ rpm -qa | grep cron
vixie-cron-4.1-83.fc7
crontabs-1.10-15.fc7

Comment 2 DaveG 2007-08-30 09:47:14 EDT
Me too.

Looks like a check has been added to the top of /usr/bin/run-parts to quit 
if "daily" jobs have not been run.

Some of us don't use anacron and some may use run-parts for other things. Is 
this an appropriate place to add such a test?

For now, just delete the cat, date and test lines from /usr/bin/run-parts.

Solutions...
1. Revert to previous version of /usr/bin/run-parts.
2. Wrap the anacron check within a test for file existance.
3. Add anacron as a "Requires".

I much prefer option 1. as this "does what it says on the tin".
Comment 3 Nerijus Baliūnas 2007-08-30 20:05:04 EDT
Also changelog says:
* An Rgp 28 2007 Marcela Maslanova <mmaslano@redhat.com> 1.10-15
- delay of running jobs is now configurable

/etc/sysconfig/crontab contains Delay=yes, but I don't see
/etc/cron.daily/000-delay.cron to use this value.
Comment 4 Marcela Mašláňová 2007-08-31 04:02:56 EDT

*** This bug has been marked as a duplicate of 269961 ***
Comment 5 Fedora Update System 2007-09-04 18:08:07 EDT
crontabs-1.10-16.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Marcela Mašláňová 2007-09-17 04:41:02 EDT
*** Bug 292621 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.