Bug 26515 - gflux hangs console
gflux hangs console
Status: CLOSED DUPLICATE of bug 26518
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-07 13:50 EST by Joshua Buysse
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-07 14:11:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Buysse 2001-02-07 13:50:12 EST
The console can be restored by killing gflux from a remote login.
Comment 1 Bill Nottingham 2001-02-07 13:53:47 EST
G200, G400, r128, i810 or Voodoo?
Comment 2 Joshua Buysse 2001-02-07 13:56:23 EST
The system has a r128.  Will add this system to the profiles on the beta site
shortly.  

The problem can also be reproduced by running /usr/X11R6/lib/xscreensaver/gflux
from the command line.  None of the other screensavers seem to show this behavior.
Comment 3 Bill Nottingham 2001-02-07 13:59:01 EST
None of the other OpenGL screensavers do this?  Odd.
I'd still wager it's a DRI problem; does it go away if you
a) run in something other than 16bpp?
b) comment out 'Load "dri"' from /etc/X11/XF86Config-4?
Comment 4 Joshua Buysse 2001-02-07 14:05:53 EST
You're right.  I hadn't tried a opengl screensaver, just a sampling of the
others.  All the opengl screensavers show the behavior, so it is likely dri.

The system is in a 32-bit mode, however, not 16-bit. I'm trying it without dri
support right now.
Comment 5 Bill Nottingham 2001-02-07 14:11:31 EST
<wanders over to test machine>

Oh, r128 supports DRI in 24bpp now. I did not know that.
In any case, reproduced here; it runs for a while and then it hangs.
Comment 6 Joshua Buysse 2001-02-07 14:13:39 EST
Confirmed that it's a DRI issue by commenting out dri in the XF86Config-4 file,
posted bug against XFree86-Servers

*** This bug has been marked as a duplicate of 26518 ***
Comment 7 Mike A. Harris 2001-02-08 22:06:24 EST
I've also confirmed this bug to exist as well under similar conditions.

Solution right now is disable DRI.  XFree86 4.0.2 DRI blows goats.
From what it looks like, DRI is not supported on Radeon, broken on r128 and
Voodoo, and matrox cards don't work at all period (yet).  Unless there are
some quick fixups to XFree86 4.0.2 DRI, perhaps in 4.0.3, there's going
to be a lot of disabled DRI drivers.  I think the cause of this is that both
the XFree DRI code is incredibly new and untested, and also the 2.4.x kernel
code is mostly new and untested, especially in combination with XFree 4.0.2.

In order to get DRI working, one will have to go to dri CVS and play.

Note You need to log in before you can comment on or make changes to this bug.