Bug 26524 - dhcpd init message redesign
Summary: dhcpd init message redesign
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: dhcp   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 26558 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-07 20:14 UTC by Christian Rose
Modified: 2007-04-18 16:31 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-08 04:50:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Christian Rose 2001-02-07 20:14:39 UTC
#: /etc/rc.d/init.d/dhcpd:26
msgid "Starting dhcpd: "

#: /etc/rc.d/init.d/dhcpd:36
msgid "Shutting down dhcpd: "

This could probably be changed to
"Starting $prog: "
and
"Shutting down $prog: "

The reason is that "dhcpd" shouldn't be translated anyway, so substituting
the name with a run-time environment variable $prog saves translators a lot
of work, instead of having to translate each similar message seperately.

Comment 1 Elliot Lee 2001-08-08 04:49:10 UTC
Apologies for the unresponsiveness of the previous dhcp packager...

Trond, can you tell me how i18n of initscripts is usually done?

Comment 2 Elliot Lee 2001-08-08 04:50:02 UTC
*** Bug 26558 has been marked as a duplicate of this bug. ***

Comment 3 Trond Eivind Glomsrxd 2001-08-08 14:26:27 UTC
Just look at the current initscript ;). This was fixed a long time ago
(2001-02-05 and improved 2001-02-07), and the fix is present in e.g. dhcp-2.0pl5-6.



Note You need to log in before you can comment on or make changes to this bug.