Bug 26560 - ntpd "usage" message redesign
Summary: ntpd "usage" message redesign
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ntp   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Preston Brown
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-07 22:42 UTC by Christian Rose
Modified: 2007-04-18 16:31 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-12 04:18:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Christian Rose 2001-02-07 22:42:52 UTC
#: /etc/rc.d/init.d/ntpd:72
msgid "Usage: ntpd {start|stop|restart|condrestart|status}"

If "ntpd" is replaced with $0 here, this message can be reused in
translations (other usage messages use $0), so that translators won't have
to translate each similar message individually. To make it more clear, what
I suggest is:

"Usage: $0 {start|stop|restart|condrestart|status}"

Comment 1 Preston Brown 2001-02-09 05:52:50 UTC

*** This bug has been marked as a duplicate of 26525 ***

Comment 2 Christian Rose 2001-02-12 04:18:16 UTC
I don't think this is a duplicate - bug 26525 talks about using $prog in the
"starting/stopping", this is about using $0 in the usage message. 
If you use $prog or $0 in both, this would be inconsistent with many other
packages, and defeat the very purpose of similar messages to make it easier for
translators by message re-use...

Comment 3 Preston Brown 2001-02-12 18:29:17 UTC
both issues were solved at the same time anyway.

Comment 4 Christian Rose 2001-02-12 22:46:40 UTC
Ok. Thanks!


Note You need to log in before you can comment on or make changes to this bug.