Bug 26649 - Installer fails to show all available array drives
Installer fails to show all available array drives
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Matt Wilson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-07 22:36 EST by Richard Black
Modified: 2005-10-31 17:00 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-26 14:47:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Black 2001-02-07 22:36:28 EST
Red Hat 7.1 Linux Beta - beta3
Feb 7, 2001
Failing HW: PL8500 tested with the following array controllers:
SA431, SA221, ROC.

Installer shows only one arrray drive while the /proc file system shows 
all array drives.  Unable to use other logical array drives during install.

Duplicatable: Yes.

Compaq Bug #: 194175

Compaq consideres this defect a  MUST-FIX for Florence.
Comment 1 Michael Fulbright 2001-02-08 11:55:09 EST

*** This bug has been marked as a duplicate of 23650 ***
Comment 2 Matt Wilson 2001-02-28 10:17:03 EST
*** Bug 28904 has been marked as a duplicate of this bug. ***
Comment 3 John Cagle 2001-03-23 12:47:17 EST
PLEASE RE-OPEN.  This is NOT a duplicate of bug 23650.

This is a makedev problem.  See bug 28904.  The problem is with 
*both* /dev/ida/ and /dev/cciss/.  Only the device nodes for the first 
controller are being created, and we need device nodes for 8 controllers.

I am also concerned that the additional device nodes may not be available 
during anaconda & kickstart, but I have not verified this.

COMPAQ considers this a MUST-FIX for 7.1!
Comment 4 Richard Black 2001-03-23 18:54:58 EST
This problem is still not fixed in RC2-qa0322.
 
Installer still shows only one array controller (tested with both multiple 
cpqarray and multiple cciss) during installation. After installation they all 
show up. It looks like the problem is in the installation process.  If you look 
at the /proc file system during installation, they (all controllers) are all 
there.
Comment 5 Michael Fulbright 2001-03-26 13:14:11 EST
Matt please investigate.
Comment 6 Matt Wilson 2001-03-26 13:16:05 EST
are you saying that both cpqarray and cciss exhibit the "sees only one
controller" problem?
Comment 7 Richard Black 2001-03-26 14:47:40 EST
Yes, with multiple cciss controllers, only the first one is seen.  With 
multiple cpqarray controllers, only the first one is seen.
Comment 8 Matt Wilson 2001-03-27 23:37:54 EST
fixed in CVS.

Note You need to log in before you can comment on or make changes to this bug.