Bug 266781 - mysql-query-browser freezes eating 100% of cpu when default schema is set
mysql-query-browser freezes eating 100% of cpu when default schema is set
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mysql-gui-tools (Show other bugs)
8
x86_64 All
medium Severity urgent
: ---
: ---
Assigned To: Dennis Gilmore
Fedora Extras Quality Assurance
:
: 371801 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-30 08:15 EDT by Vaclav "sHINOBI" Misek
Modified: 2008-09-16 03:32 EDT (History)
5 users (show)

See Also:
Fixed In Version: 5.0r12-4.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-06 15:55:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix lockup when setting the default schema (573 bytes, patch)
2007-10-06 11:23 EDT, Jimmy Rentz
no flags Details | Diff
Specfile to apply the previous patch (6.53 KB, text/x-rpm-spec)
2007-11-27 06:07 EST, István Tóth
no flags Details

  None (edit)
Description Vaclav "sHINOBI" Misek 2007-08-30 08:15:49 EDT
Description of problem:
When default schema is set in connection dialog, query browser freezes eating
100% of cpu.

Version-Release number of selected component (if applicable):
mysql-query-browser-5.0r12-2.fc8

How reproducible:
Always

Steps to Reproduce:
1. Start mysql-query-browser
2. Try to set default schema
3. Freeze
  
Actual results:
Even after logging in to the server, the client freezes when schema is set.
Seems to be bug similar bug as #30055 from http://bugs.mysql.com.

Expected results:
Query browser should be working.

Additional info:
Comment 1 Jimmy Rentz 2007-10-06 11:23:40 EDT
Created attachment 218451 [details]
Patch to fix lockup when setting the default schema

This patch fixes a problem when setting the default schema in
mysql-query-browser.

The problem is a race condition (read memory after it is freed) that only seems
to occur when setting the default schema.
Comment 2 Benjamin Bach 2007-10-23 09:05:57 EDT
I get this, too. Even when writing "USE dbname" in the query field. Would anyone
care to release an update really quickly? :)
Comment 3 Vaclav "sHINOBI" Misek 2007-11-01 07:37:28 EDT
I can confirm, that the patch in comment #1 solves the problem for me. Could the
package be rebuild officially in koji as this bug is really ugly?
Comment 4 Edward Rudd 2007-11-20 11:42:01 EST
This issue still exists in the mysql-query-browser-5.0r12-3.fc8 package in F8
release.  This bug makes mysql-query-browser compltely useless.
Comment 5 Matt Baker 2007-11-21 10:18:12 EST
I'm also having this issue in the i386 F8 release, package
mysql-query-browser-5.0r12-3.fc8.  I agree with Eddie that this makes
mysql-query-browser useless.
Comment 6 István Tóth 2007-11-27 06:07:30 EST
Created attachment 269611 [details]
Specfile to apply the previous patch

This spec file builds workings rpms is you save the prevoius patch file
as "mysql-query-browser-race.patch" in the SOURCES directory
Comment 7 Aaron Hagopian 2007-11-27 16:01:44 EST
same prob for me too on x64_64 f8.

Any plans on moving this patch to updates-testing?  This is really annoying
since its an app I use quite often.
Comment 8 Levente Farkas 2007-11-28 06:51:06 EST
the above patch do not fix the problem for me:-(
Comment 9 Fedora Update System 2007-11-28 20:45:47 EST
mysql-gui-tools-5.0r12-4.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update mysql-gui-tools'
Comment 10 Aaron Hagopian 2007-11-29 10:26:03 EST
I tried to install the update through yum and it does not appear to be in the
repository yet, i even tried yum clean all to make sure nothing was stale and
its still not there.

I found the rpms on the koji site and installed them and can verify that
mysql-gui-tools-5.0r12-4.fc8 does seem to be working properly for me now.
Comment 11 Edward Rudd 2007-11-29 11:00:32 EST
Downloaded the updates/testing/8 x86_64 rpms and they work properly on my
system.. Thanks for getting the updated build out :)
Comment 12 Fedora Update System 2007-12-06 15:55:30 EST
mysql-gui-tools-5.0r12-4.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Julian 2008-07-29 13:33:42 EDT
I installed 5.0r12-4.fc8 through yum and the problem is still there.  The
application is essentially unusable.  Is there something in the testing
repository that I can try?  
Comment 14 Pavel Alexeev 2008-08-04 07:37:10 EDT
Please see bug http://bugs.mysql.com/bug.php?id=30055

And I'm include patch in my src.rpm http://hubbitus.net.ru/rpm/Fedora9/mysql-gui-tools/mysql-gui-tools-5.0r12-1.fc9.Hu.10.src.rpm (mysql-gui-tools.chema_change_freeze_bug.patch).

Please revisit it. It's worked for me very well.
Comment 15 Pavel Alexeev 2008-09-16 03:32:19 EDT
*** Bug 371801 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.