Bug 26683 - XFree86-4.0.2 fails with S3virge
Summary: XFree86-4.0.2 fails with S3virge
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 28052 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-08 11:39 UTC by Sarantis Paskalis
Modified: 2007-04-18 16:31 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-25 14:25:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Sarantis Paskalis 2001-02-08 11:39:11 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.0-0.99.11 i586)


XFree86-4.0.2 does not work properly with my Diamond Multimedia 3D 2000
video card.
It brings up the display, which is kind of divided in 3 similar vertical
pieces, where
it should show only one.  The flickering is also very intense.
RedHat's previous XFree-4 (the guinness default) worked, although
Xconfigurator recommended
XFree86-3.3.6

Xconfigurator seems to create an XFree-4 config file by default, and I had
to issue a --preferxf3 (or similar) to have a running X server.

Configuring by other means (xf86config, xf86cfg, manual XF86Config editing)
gives the same results.

Reproducible: Always
Steps to Reproduce:
1. Xconfigurator recognizes my Video Card PCI Entry S3 Inc.|86c325 [ViRGE]
2. Select my Monitor Sony CPD-15SF2
3. Issue my video memory 2MB
4. Select No Clockchip Setting
5. Select 1152x864x16bpp
6. X starts and displays these horizontally compressed and mixed stuff. 
The vertical axon behaves correctly.

Comment 1 Mike A. Harris 2001-02-17 16:32:42 UTC
*** Bug 28052 has been marked as a duplicate of this bug. ***

Comment 2 Matthew Kirkwood 2001-02-17 21:06:38 UTC
If it matters, my ViRGE (bug 28052) is exactly the same model.  lspci output:

00:09.0 VGA compatible controller: S3 Inc. 86c325 [ViRGE] (rev 06) (prog-if 00
[VGA])
	Flags: bus master, medium devsel, latency 64, IRQ 10
	Memory at e0000000 (32-bit, non-prefetchable) [size=64M]
	Expansion ROM at <unassigned> [disabled] [size=64K]



Comment 3 Mike A. Harris 2001-02-25 14:25:26 UTC
Yes, the recommended way to fix this is to run XConfigurator --preferxf3

The S3 support in XFree86 4.0.2 is a bit shaky.  Hopefully 4.0.3 will have
fixed these bugs.

Comment 4 Mike A. Harris 2001-02-25 14:27:46 UTC
Xconfigurator has been fixed to default his card to XFree-Servers 3.3.6 now.
This will be in the next rawhide release.

Comment 5 Sarantis Paskalis 2001-03-07 09:50:26 UTC
XFree86-4.0.2 as shipped in wolverine works again with S3virge.  I note again
that it was only fisher that did not work correctly with XFree86-4.0.2




Note You need to log in before you can comment on or make changes to this bug.