Bug 267261 - SSID parameter empty on probe of hidden network
SSID parameter empty on probe of hidden network
Status: CLOSED DUPLICATE of bug 373841
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
7
All All
medium Severity low
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-30 10:36 EDT by Russell Harrison
Modified: 2008-01-10 18:37 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-10 18:37:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Russell Harrison 2007-08-30 10:36:06 EDT
I got the chance to do some network sniffing with one of our network guys today.
 We've noticed that the SSID parameter issued by NetworkManager with cards using
the iwl drivers is empty.  On a previous version of NM (FC6) on a machine with
the 2945 card the same parameter comes across with the SSID properly set.

NetworkManger has been having some problems with hidden networks recently and
this would seem to be a very big pointer into why.  When NM probes the AP with
an empty (or broadcast) SSID it will respond only with the SSIDs that it is
broadcasting.  To connect to hidden networks NM needs to probe the AP with the
SSID parameter set.

I have some dump files but need to go over them to make sure they don't need to
be sanitized before posting them in a public space.
Comment 1 Dan Williams 2007-08-30 12:14:56 EDT
This is somewhat intricate, there are a few parts.

First, NetworkManager.  NM will tell wpa_supplicant to use the "scan_ssid=1"
option when the network is hidden (or at least it should).  NM doesn't do
anything with probe requests at all, it defers it to wpa_supplicant.

Second, wpa_supplicant.  If given the "scan_ssid=1" option for a network, it
_should_ tell the driver to generate a specific SSID probe request during the scans.

Third, the driver.  The driver has to respect the specific SSID probe request
given to it by wpa_supplicant.  Not many drivers do...

So it's possible that the bug is in any one of these 3 places.  We'd need to see
from /var/log/messages what NM thinks its doing, and then possibly update your
copy of wpa_supplicant with one that logs output to a file.  Either that, or
turn on debugging in the driver.

What driver are you using?  What kernel version?  Can you attach the output of
lspci?

thanks...
Comment 2 Dan Williams 2008-01-10 18:37:00 EST
I've submitted an upstream kernel patch that Linville has been backporting to
the Fedora 2.6.23 kernels that allows NM to make an intelligent decision whether
or not to use ap_scan=1 or ap_scan=2.  I've updated NetworkManager to pass the
correct ap_scan value when the driver supports scanning specific SSIDs.

*** This bug has been marked as a duplicate of 373841 ***

Note You need to log in before you can comment on or make changes to this bug.