Bug 26790 - lilo didn't edit lilo.conf to have new kernel
lilo didn't edit lilo.conf to have new kernel
Status: CLOSED DUPLICATE of bug 31194
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-09 03:20 EST by Telsa Gwynne
Modified: 2007-04-18 12:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-02 11:30:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Telsa Gwynne 2001-02-09 03:20:42 EST
The summary is a guess at the cause.

Cyrix MediaGX, 32megs. Already had an old 6.9 beta on it,
so did upgrade, via "text expert". Told it boot loader
should go on MBR, tweaked the selection of packages it
offered me, but didn't go near stuff like lilo, just dinked
with my favourite MUA, etc.

Rebooted, needed an -ac kernel to fix something, grabbed
that, went to edit /etc/lilo.conf and um. The 2.4 kernel
which should have been there wasn't mentioned in the file.
Sure enough, although the new kernel had been installed,
I was running a 2.2...

/tmp/upgrade has "Upgrading kernel" and "Upgrading lilo".
I find a kernel-BOOT rpm in the list of "not picked". Is
this something I should have known about?
Comment 1 Doug Ledford 2001-02-09 06:35:29 EST
lilo never has edited config files on upgrades.  This is the responsibility of
the installer.  I'm changing assingment to msw so that he can make sure this is
a (most likely) already fixed issue in the installer.
Comment 2 Michael Fulbright 2001-04-02 11:30:39 EDT
Matt did your fix recently address this issue?
Comment 3 Matt Wilson 2001-04-02 11:33:52 EDT

*** This bug has been marked as a duplicate of 31194 ***

Note You need to log in before you can comment on or make changes to this bug.