Bug 26924 - rc.sysinit changes fonts/size overriding kernel default
Summary: rc.sysinit changes fonts/size overriding kernel default
Status: CLOSED DUPLICATE of bug 26901
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts   
(Show other bugs)
Version: 7.1
Hardware: All Linux
high
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-10 07:21 UTC by Mike A. Harris
Modified: 2014-03-17 02:18 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-10 07:21:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mike A. Harris 2001-02-10 07:21:29 UTC
The rc.sysinit script calls setsysfont automatically setting the
system font without regard to the default font one may have selected
at boot time via lilo.  This occured in Red Hat 5.0 or 5.1 also, and
the only solution I had was to remove the /sbin/setsysfont execute
permission.

I start my system up with vga=extended in lilo.conf in order to get
an 80x50 text screen.  During rc.sysinit, once setsysfont gets called,
the system switches to 80x25 mode thus killing all my nice real estate.
;o)

I've worked around it with "chmod a-x /sbin/setsysfont" for now.  Perhaps
rm /sbin/setsysfont is better.  ;o)

Comment 1 Bill Nottingham 2001-02-10 07:30:17 UTC

*** This bug has been marked as a duplicate of 26901 ***


Note You need to log in before you can comment on or make changes to this bug.