Bug 26901 - initscripts overrides kernel command line
Summary: initscripts overrides kernel command line
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 26924 28544 44108 45011 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-10 01:07 UTC by adam.huffman
Modified: 2014-03-17 02:18 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-10 07:30:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description adam.huffman 2001-02-10 01:07:27 UTC
vga=1 is in my kernel command line and the kernel does boot into that mode
but it changes to 80x25 when the console font part of rc.sysinit runs.

A problem possibly related to this is that with a custom-compiled kernel
the console font is not set correctly;  anything blue has a line through it
and is thus nearly unreadable.

Here are the contents of /etc/sysconfig/i18n (as set during installation):

LANG="en_GB"
SUPPORTED="en_GB:en:en_US:en"
SYSFONT="default8x16"
SYSFONTACM="iso01"

Comment 1 Bill Nottingham 2001-02-10 01:46:48 UTC
This is messy to fix; you do want to be able to load the default font, so
that proper international characters can be displayed correctly.

Comment 2 Bill Nottingham 2001-02-10 07:30:12 UTC
*** Bug 26924 has been marked as a duplicate of this bug. ***

Comment 3 Bill Nottingham 2001-02-12 03:17:44 UTC
After some testing of possible solutions, I've determined that this isn't really
fixable in initscripts. My best suggestion is to either remove 
the SYSFONT line, or change it to something appropriate to whatever resolution
you're booting into.

Comment 4 Bill Nottingham 2001-02-21 07:07:31 UTC
*** Bug 28544 has been marked as a duplicate of this bug. ***

Comment 5 Bill Nottingham 2001-06-11 14:40:16 UTC
*** Bug 44108 has been marked as a duplicate of this bug. ***

Comment 6 Bill Nottingham 2001-06-19 20:03:58 UTC
*** Bug 45011 has been marked as a duplicate of this bug. ***

Comment 7 Robin Whittle 2001-06-20 03:05:07 UTC
My solution, which reminds me of what I have done rather than just having a line deleted in some obscure config file I won't remember, is 
to add the following lines after the first line in /sbin/setsysfont:

echo $"/sbin/setsysfont modified to not change system font - so as not to upset >25 line console"
exit 1


There seems to be two attempts to use /sbin/setsysfont.  The first is as part of /etc/rc.d/rc.sysinit. The above modification causes this 
attempt to fail visibly, with the above text appearing on screen.  

The second is almost at the end of the boot procedure, when I think /etc/rc.d/init.d/keytable calls /sbin/setsysfont again.  In that case the 
text "Starting keytable OK" appears.


Note You need to log in before you can comment on or make changes to this bug.