Bug 269681 - x86_64 eclipse doesn't start up with 32 bit runtime (icedtea)
x86_64 eclipse doesn't start up with 32 bit runtime (icedtea)
Status: CLOSED DUPLICATE of bug 271761
Product: Fedora
Classification: Fedora
Component: java-1.7.0-icedtea (Show other bugs)
rawhide
All All
medium Severity low
: ---
: ---
Assigned To: Thomas Fitzsimmons
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-30 17:51 EDT by Mark Wielaard
Modified: 2007-11-30 17:12 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-05 17:16:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Wielaard 2007-08-30 17:51:38 EDT
Description of problem:

When starting eclipse on x86_64 when a 32bit java runtime is the default eclipse
doesn't start and just shows a crash dialog that doesn't help finding the
problem. The problem is that it tries to load swt-gtk-3346.so which is only
available in a 64bit version (libswt3-gtk2.x86_64)

Version-Release number of selected component (if applicable):

eclipse-platform-3.3.0-9.fc8

How reproducible:

always (when the 32bit icedtea runtime is the default)

Steps to Reproduce:
1. yum install java-1.7.0-icedtea
2. eclipse
  
Actual results:

confusing crash dialog

Expected results:

eclipse just starts or at least lets me know that a 64bit swt-gtk library was
loaded by a 32bit runtime (and that this doesn't work).

Additional info:

This should probably (also) be filed against icedtea because when you install
java-1.7.0-icedtea* the 32bit version is the default:

   1           /usr/lib/jvm/jre-1.5.0-gcj/bin/java
*+ 2           /usr/lib/jvm/jre-1.7.0-icedtea/bin/java
   3           /usr/lib/jvm/jre-1.7.0-icedtea.x86_64/bin/java

But icedtea doesn't exist yet in bugzilla, so for now filed under eclipse (which
should at least detect and provide a clue about what is happening to the user).
Please clone when icedtea gets its own component.
Comment 1 Ben Konrath 2007-08-30 17:54:34 EDT
I think this is an IcedTea issue. The 64-bit version of java should be the default.
Comment 2 Mark Wielaard 2007-08-31 05:00:54 EDT
(In reply to comment #1)
> I think this is an IcedTea issue. The 64-bit version of java should be the
default.

Yes, it is firstly an IcedTea issue. I just couldn't find the icedtea component
in bugzilla yesterday. But Eclipse didn't help at all finding the root cause. it
should at least have indicated why it wasn't properly starting up.

BTW. This issue also affects the webplugin, firefox used to just hang whenever a
applet was loaded, but switching the java alternative to the x86_64 version made
applets work! yeah. All in all the icedtea packages are pretty cool, just the
default to the 32bit version after doing a yum install java-1.7.0-icedtea* was a
little problem.
Comment 3 Thomas Fitzsimmons 2007-09-05 17:16:20 EDT

*** This bug has been marked as a duplicate of 271761 ***

Note You need to log in before you can comment on or make changes to this bug.