Bug 26987 - setperms shell script error
setperms shell script error
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
David Lawrence
:
: 26332 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-10 16:54 EST by Sam Varshavchik
Modified: 2007-04-18 12:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-13 11:48:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sam Varshavchik 2001-02-10 16:54:05 EST
This is the bind-9.1.0-2.i386 package from fisher:

# rpm --setperms bind
sh: line 67: syntax error: unexpected end of file


Reproducible: Always
Steps to Reproduce:
1. Install bind-9.1.0-2 from fisher
2. run rpm --setperms bind

	

straced it, looks like the initial output from rpmq is truncated.
Comment 1 Glen Foster 2001-02-12 18:01:07 EST
This defect is considered MUST-FIX for Florence Release-Candidate #1
Comment 2 Tim Waugh 2001-02-13 11:48:22 EST
This looks just like bug 26332.
Comment 3 Jeff Johnson 2001-02-13 13:36:33 EST
Yup, fixed size buffer fed to vsnprintf. Fixed in rpm-4.0.2-0.37.
Comment 4 Jeff Johnson 2001-02-13 13:37:29 EST
*** Bug 26332 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.