Bug 270181 - yum crash updating some packages from atrpms
yum crash updating some packages from atrpms
Status: CLOSED DUPLICATE of bug 252461
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
7
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-31 00:01 EDT by Roland Roberts
Modified: 2014-01-21 17:59 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-31 00:15:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roland Roberts 2007-08-31 00:01:07 EDT
On a freshly installed fc7 system, I attempted to run yum update and got a
crash.  After updating packages selectively, I narrowed it down to flac. 
Later, yum check-update reported lirc also has an update, both from atrpms. 
Either one triggers the crash, shown below.

I am also reporting this on the atrpms bugzilla against yum since I can't tell
where the problem comes from.  No fc7 packages have been seen to trigger this
and most atrpms updated just fine, too.

[root@aristarchus ~]# yum check-update

flac.i386                                1.1.4-4_12.fc7         atrpms          
lirc.i386                                0.8.3-70_cvs20070827.f atrpms          
[root@aristarchus ~]# yum update
Setting up Update Process
atrpms                    100% |=========================|  951 B    00:00     
http://mirror.nuvio.com/pub/fedora/linux/releases/7/Everything/i386/os/repodata/repomd.xml:
[Errno 12] Timeout: <urlopen error timed out>
Trying other mirror.
fedora                    100% |=========================| 2.1 kB    00:00     
adobe-linux-i386          100% |=========================|  951 B    00:00     
http://mirror.nuvio.com/pub/fedora/linux/updates/7/i386/repodata/repomd.xml:
[Errno 12] Timeout: <urlopen error timed out>
Trying other mirror.
updates                   100% |=========================| 1.9 kB    00:00     
Resolving Dependencies
--> Running transaction check
---> Package lirc.i386 0:0.8.3-70_cvs20070827.fc7 set to be updated
---> Package flac.i386 0:1.1.4-4_12.fc7 set to be updated
--> Processing Dependency: libFLAC.so.8 for package: xmms-flac
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 135, in main
    (result, resultmsgs) = base.buildTransaction() 
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 540, in
buildTransaction
    (rescode, restring) = self.resolveDeps()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 885, in
resolveDeps
    (checkdep, missing, conflict, errormsgs) = self._processReq(dep,
prcoformat_need)
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 334, in
_processReq
    requirementTuple, errormsgs)
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 469, in
_requiringFromInstalled
    return self._requiringFromTransaction(reqpkg, requirement, errorlist)
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 574, in
_requiringFromTransaction
    reqpkg = self.tsInfo.matchNaevr(name=name, ver=version, rel=release)[0]
IndexError: list index out of range
Comment 1 Seth Vidal 2007-08-31 00:15:20 EDT

*** This bug has been marked as a duplicate of 252461 ***

Note You need to log in before you can comment on or make changes to this bug.