Bug 252461 - IndexError traceback in depsolve._requiringFromTransaction
IndexError traceback in depsolve._requiringFromTransaction
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
: 270021 270181 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-16 01:34 EDT by Luke Macken
Modified: 2016-09-19 22:37 EDT (History)
8 users (show)

See Also:
Fixed In Version: 3.2.4-2.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-04 18:12:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
tar of /var/lib/rpm (15.39 MB, application/octet-stream)
2007-08-17 12:12 EDT, Simo Sorce
no flags Details

  None (edit)
Description Luke Macken 2007-08-16 01:34:35 EDT
Description of problem:
$ sudo yum -y update
Loading "fastestmirror" plugin
Setting up Update Process
Loading mirror speeds from cached hostfile
Resolving Dependencies
--> Running transaction check
---> Package directfb.i386 0:1.0.0-14.fc7 set to be updated
--> Processing Dependency: libfusion-1.0.so.0 for package: directfb
--> Processing Dependency: libdirectfb-1.0.so.0 for package: mplayer
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 135, in main
    (result, resultmsgs) = base.buildTransaction().
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 540, in
buildTransaction
    (rescode, restring) = self.resolveDeps()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 885, in resolveDeps
    (checkdep, missing, conflict, errormsgs) = self._processReq(dep,
prcoformat_need)
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 334, in _processReq
    requirementTuple, errormsgs)
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 469, in
_requiringFromInstalled
    return self._requiringFromTransaction(reqpkg, requirement, errorlist)
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 574, in
_requiringFromTransaction
    reqpkg = self.tsInfo.matchNaevr(name=name, ver=version, rel=release)[0]
IndexError: list index out of range


Version-Release number of selected component (if applicable):
yum-3.2.2-1.fc7

How reproducible:
Always
Comment 1 Jason Tibbitts 2007-08-17 01:35:18 EDT
I'm seeing the same backtrace with the same yum version.
Comment 2 Jason Tibbitts 2007-08-17 01:39:59 EDT
Actually mine isn't exactly the same; I'm running:

/usr/bin/yum -y -d3 shell /etc/yum/yum-daily.yum

where yum-daily.yum contains:

update
ts run
groupupdate math-base
groupupdate math-dev
groupupdate math-emacs
ts run
clean packages
exit

I expect the extra bits are immaterial, but in any case, the backtrace is:

Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 94, in main
    result, resultmsgs = base.doCommands()
  File "/usr/share/yum-cli/cli.py", line 267, in doCommands
    return self.yum_cli_commands[self.basecmd].doCommand(self, self.basecmd, self.extcmds)
  File "/usr/share/yum-cli/yumcommands.py", line 397, in doCommand
    return base.doShell()
  File "/usr/share/yum-cli/cli.py", line 223, in doShell
    yumshell.script()
  File "/usr/share/yum-cli/shell.py", line 69, in script
    self.onecmd(line)
  File "/usr/lib64/python2.5/cmd.py", line 219, in onecmd
    return func(arg)
  File "/usr/share/yum-cli/shell.py", line 156, in do_ts
    self.do_transaction(line)
  File "/usr/share/yum-cli/shell.py", line 182, in do_transaction
    return self.do_run('')
  File "/usr/share/yum-cli/shell.py", line 312, in do_run
    (code, msgs) = self.base.buildTransaction()
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 540, in buildTransaction
    (rescode, restring) = self.resolveDeps()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 885, in resolveDeps
    (checkdep, missing, conflict, errormsgs) = self._processReq(dep, prcoformat_need)
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 334, in _processReq
    requirementTuple, errormsgs)
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 469, in _requiringFromInstalled
    return self._requiringFromTransaction(reqpkg, requirement, errorlist)
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 574, in _requiringFromTransaction
    reqpkg = self.tsInfo.matchNaevr(name=name, ver=version, rel=release)[0]
IndexError: list index out of range

Comment 3 Simo Sorce 2007-08-17 12:12:53 EDT
Created attachment 161752 [details]
tar of /var/lib/rpm

Similar happening to me as well, after talks with skvidal on #fedora-devel I am
attaching a tar of /var/lib/rpm
Comment 4 Seth Vidal 2007-08-17 12:55:57 EDT
anyone who can replicate this - are you on x86_64?
Comment 5 Seth Vidal 2007-08-17 13:18:30 EDT
anyone who can replicate this bug: download this src.rpm
http://skvidal.fedorapeople.org/yum-3.2.3-0.pre.fc8.src.rpm

build the srpm and tell me if it changes the result.

thanks

Comment 6 Luke Macken 2007-08-17 15:52:12 EDT
Works for me.
Comment 7 Seth Vidal 2007-08-17 16:59:14 EDT
luke, really? Anything else change? if you go back to the older yum does it
still break?
Comment 8 Luke Macken 2007-08-17 18:00:24 EDT
Everything looked kosher with 3.2.3.  I can't reproduce this traceback when
going back to yum-3.2.2-1.fc7 (I also can't reproduce the same transaction from
before either).  This is on x86.
Comment 9 Herbert Gasiorowski 2007-08-21 02:58:19 EDT
Still have the Problem:

# rpm -q yum
yum-3.2.3-0.pre.fc7

yum update
fedora                    100% |=========================| 2.1 kB    00:00     
fb12                      100% |=========================|  951 B    00:00     
updates                   100% |=========================| 1.9 kB    00:00     
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package kdelibs.i386 6:3.5.7-20.fc7 set to be updated
---> Package kdelibs-devel.i386 6:3.5.7-20.fc7 set to be updated
---> Package kdebase-devel.i386 6:3.5.7-13.fc7 set to be updated
---> Package kdebase.i386 6:3.5.7-13.fc7 set to be updated
---> Package kdebindings.i386 0:3.5.7-1.fc7.1 set to be updated
---> Package kdelibs-apidocs.i386 6:3.5.7-20.fc7 set to be updated
--> Processing Dependency: kde-filesystem for package: kdelibs
--> Processing Dependency: perl(DCOP) for package: kdesdk
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 143, in main
    (result, resultmsgs) = base.buildTransaction() 
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 556, in
buildTransaction
    (rescode, restring) = self.resolveDeps()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 896, in resolveDeps
    (checkdep, missing, conflict, errormsgs) = self._processReq(dep,
prcoformat_need)
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 344, in _processReq
    requirementTuple, errormsgs)
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 479, in
_requiringFromInstalled
    return self._requiringFromTransaction(reqpkg, requirement, errorlist)
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 584, in
_requiringFromTransaction
    reqpkg = self.tsInfo.matchNaevr(name=name, ver=version, rel=release)[0]
IndexError: list index out of range
Comment 10 Herbert Gasiorowski 2007-08-23 05:23:20 EDT
As the problem still exist (for me, see Comment #9) and the updates are blocked
for 5 hosts and the priority of this bug is low,
I decided to install the original yum (3.2.0) and to update:
This worked fine and yum is again on 3.2.2 and no more errors - until the next
kde update or something like that.

I left one machine with the error - so if there is any question ask me now
before i "fixed" it too.
Comment 11 Orion Poplawski 2007-08-23 17:13:32 EDT
Me too.

# yum -y upgrade -d3
Loading "dellsysidplugin" plugin
Running "postconfig" handler for "dellsysidplugin" plugin
Running "init" handler for "dellsysidplugin" plugin
Yum Version: 3.2.2
COMMAND: yum -y upgrade -d3
Installroot: /
Setting up Upgrade Process
Reading Local RPMDB
Building updates object
Setting up Package Sacks
Resolving Dependencies
1187902325.02
--> Running transaction check
---> Package kdebindings.i386 0:3.5.7-1.fc7.1 set to be updated
---> Package dell-firmware-repository.noarch 0:1-3 set to be updated
# of Deps = 1
--> Processing Dependency: perl(DCOP) for package: kdesdk
Matched kdebindings - 3.5.6-1.fc7.i386 to require for perl(DCOP)
Matched kdebindings-dcopperl - 3.5.7-1.fc7.1.i386 to require for perl(DCOP)
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 135, in main
    (result, resultmsgs) = base.buildTransaction()
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 540, in
buildTransaction
    (rescode, restring) = self.resolveDeps()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 885, in resolveDeps
    (checkdep, missing, conflict, errormsgs) = self._processReq(dep,
prcoformat_need)
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 334, in _processReq
    requirementTuple, errormsgs)
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 469, in
_requiringFromInstalled
    return self._requiringFromTransaction(reqpkg, requirement, errorlist)
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 574, in
_requiringFromTransaction
    reqpkg = self.tsInfo.matchNaevr(name=name, ver=version, rel=release)[0]
IndexError: list index out of range

# rpm -Uvh /data/sw1/test/yum-3.2.3-0.pre.fc7.noarch.rpm
Preparing...                ########################################### [100%]
   1:yum                    ########################################### [100%]

# yum -y upgrade -d3
Loading "dellsysidplugin" plugin
Running "postconfig" handler for "dellsysidplugin" plugin
Running "init" handler for "dellsysidplugin" plugin
Yum Version: 3.2.2
COMMAND: yum -y upgrade -d3
Installroot: /
Reading Local RPMDB
Setting up Package Sacks
Setting up Upgrade Process
Building updates object
Resolving Dependencies
1187902744.81
--> Running transaction check
---> Package kdebindings.i386 0:3.5.7-1.fc7.1 set to be updated
---> Package dell-firmware-repository.noarch 0:1-3 set to be updated
# of Deps = 1
--> Processing Dependency: perl(DCOP) for package: kdesdk
Matched kdebindings - 3.5.6-1.fc7.i386 to require for perl(DCOP)
Matched kdebindings-dcopperl - 3.5.7-1.fc7.1.i386 to require for perl(DCOP)
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 143, in main
    (result, resultmsgs) = base.buildTransaction()
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 556, in
buildTransaction
    (rescode, restring) = self.resolveDeps()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 896, in resolveDeps
    (checkdep, missing, conflict, errormsgs) = self._processReq(dep,
prcoformat_need)
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 344, in _processReq
    requirementTuple, errormsgs)
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 479, in
_requiringFromInstalled
    return self._requiringFromTransaction(reqpkg, requirement, errorlist)
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 584, in
_requiringFromTransaction
    reqpkg = self.tsInfo.matchNaevr(name=name, ver=version, rel=release)[0]
IndexError: list index out of range

Works with 3.2.3-2 from current rawhide:

# rpm -Uvh /data/sw1/test/yum-3.2.3-2.fc7.noarch.rpm
Preparing...                ########################################### [100%]
   1:yum                    ########################################### [100%]
# yum -y upgrade -d3
Loading "dellsysidplugin" plugin
Running "postconfig" handler for "dellsysidplugin" plugin
Running "init" handler for "dellsysidplugin" plugin
Yum Version: 3.2.3
COMMAND: yum -y upgrade -d3
Installroot: /
Reading Local RPMDB
Setting up Package Sacks
fwupdate                  100% |=========================| 1.9 kB    00:00
dell-software             100% |=========================| 1.9 kB    00:00
fedora                    100% |=========================| 2.1 kB    00:00
adobe-linux               100% |=========================|  951 B    00:00
dell-hardware-auto        100% |=========================| 1.9 kB    00:00
livna                     100% |=========================| 2.1 kB    00:00
updates                   100% |=========================| 1.9 kB    00:00
dell-hardware-main        100% |=========================| 1.9 kB    00:00
CoRA                      100% |=========================|  951 B    00:00
Setting up Upgrade Process
Building updates object
Resolving Dependencies
1187903438.22
--> Running transaction check
---> Package kdebindings.i386 0:3.5.7-1.fc7.1 set to be updated
--> Processing Dependency: perl(DCOP) for package: kdesdk
Matched kdebindings - 3.5.6-1.fc7.i386 to require for perl(DCOP)
Matched kdebindings-dcopperl - 3.5.7-1.fc7.1.i386 to require for perl(DCOP)
TSINFO: Marking kdebindings-dcopperl - 3.5.7-1.fc7.1.i386 as install for kdesdk
---> Package dell-firmware-repository.noarch 0:1-3 set to be updated
--> Running transaction check
---> Package kdebindings-dcopperl.i386 0:3.5.7-1.fc7.1 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved
Comment 12 Orion Poplawski 2007-08-23 18:57:03 EDT
This might be part of the problem:

# yum provides 'perl(DCOP)'
kdebindings-dcopperl.x86_64              3.5.7-1.fc7.1          updates
Matched from:
perl(DCOP)

kdebindings.i386                         3.5.6-1.fc7            fedora
Matched from:
perl(DCOP)

kdebindings.x86_64                       3.5.6-1.fc7            fedora
Matched from:
perl(DCOP)

kdebindings.x86_64                       3.5.6-1.fc7            installed
Matched from:
Provides-match: perl(DCOP)

- both kdebindings and kdebindings-dcopperl providing perl(DCOP).
Comment 13 Seth Vidal 2007-08-31 00:15:21 EDT
*** Bug 270181 has been marked as a duplicate of this bug. ***
Comment 14 Jeremy Katz 2007-08-31 08:59:07 EDT
*** Bug 270021 has been marked as a duplicate of this bug. ***
Comment 15 Fedora Update System 2007-09-04 18:12:07 EDT
yum-3.2.4-2.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.