Bug 27059 - gmc mounting/unmounting of devices succeeds, but pops up bogus warning dialogs
gmc mounting/unmounting of devices succeeds, but pops up bogus warning dialogs
Status: CLOSED DUPLICATE of bug 29791
Product: Red Hat Linux
Classification: Retired
Component: magicdev (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-11 12:56 EST by Ed McKenzie
Modified: 2007-04-18 12:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-26 23:27:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ed McKenzie 2001-02-11 12:56:34 EST
IMO, workstation-class installs should append the 'user' option to CD-ROM
and floppy devices in /etc/fstab. 'Workstation' tends to imply 'single
user,' and ideally that single user shouldn't be root.
Comment 1 Jeremy Katz 2001-02-11 17:12:26 EST
Removable devices are given the 'owner' flag by default, allowing the user who
owns the device to mount it.  This coupled with pam_console chown'ing devices on
login should be sufficent for letting the user currently logged into the console
mount removable devices.
Comment 2 Ed McKenzie 2001-02-11 17:15:33 EST
Then perhaps gmc should be patched so these devices work without 'user'? As it
is, gmc won't eject/mount/umount desktop devices as anyone but root.
Comment 3 Jeremy Katz 2001-02-11 17:23:44 EST
Actually, gmc is mounting and unmounting the devices properly but not
interpreting the results of the mount properly... on mount, I get a warning
dialog box with gibberish or nothing and get similar warnings on unmount.
Reassigning to gmc and changing the subject to match the real problem
Comment 4 Glen Foster 2001-02-12 18:14:52 EST
We (Red Hat) should really try to resolve this before next release.
Comment 5 Elliot Lee 2001-02-13 19:31:39 EST
I don't see this bug. Can you provide detailed instructions on reproducing it?
Comment 6 Ed McKenzie 2001-02-14 00:27:27 EST
This happens whenever I mount or unmount CD devices as a non-root user (haven't
tried it as root.) I get error dialogs with garbage, but the mount appears to
succeed anyway.

If it makes a difference, I do have two CD drives on this box.
Comment 7 Elliot Lee 2001-02-19 12:39:04 EST
Like I said, works fine for me. I'm not really sure how to proceed without being
able to make it happen here.
Comment 8 Jeremy Katz 2001-02-26 23:27:23 EST
I'm seeing this without fail on a fresh install of 20010226 rawhide with
gmc-4.5.51-25 and magicdev-0.3.0-4.  From looking at straces of both gmc and
magicdev, I don't think it's magicdev though (especially as I've only seen it on
manual mounts or double-click to open and mount).  Now for the really weird bit,
I've only gotten it to happen on the first login after removing all of my
.gnome* and .mc* directories.

The exact steps to reproducing were:
1) install
2) log in as non-root user (fresh account)
3) with floppy in drive, right click on floppy icon and click mount
   (alternately, double click for open)
4) see warning pop up
5) right click on floppy and select unmount device, see similar warning
Comment 9 Elliot Lee 2001-03-15 17:15:40 EST

*** This bug has been marked as a duplicate of 29791 ***

Note You need to log in before you can comment on or make changes to this bug.